Mailinglist Archive: opensuse-buildservice (63 mails)

< Previous Next >
Re: [opensuse-buildservice] All project targets report "repository setup is broken, build not possible" and api.opensuse.org/public is down
I was definitely using /public, and it definitely broke.

This was the Meta:

<project name="openSUSE.org">
<title>Standard OBS instance at build.opensuse.org</title>
<description>This instance delivers the default build targets for
OBS.</description>
<remoteurl>https://api.opensuse.org/public</remoteurl>
<person userid="Admin" role="bugowner"/>
<person userid="Admin" role="maintainer"/>
</project>


The logs have already rotated away, sorry. I was referring to local
builds hanging, as they had opensuse.org at the end of the repository
search path.

-Matt
On Mon, 2016-01-25 at 18:14 +0100, Adrian Schröter wrote:
On Montag, 25. Januar 2016, 11:25:53 CET wrote Neal Gompa:
On Mon, Jan 25, 2016 at 8:45 AM, Matthew Drobnak <mdrobnak@xxxxxxxxxxxx>
wrote:
I had to remove my remote link to opensuse.org because of this issue.
Any project which included it in search paths hung forever on my private
2.4 instance. (Yes, I know I need to upgrade. It's on the list. :) )

It was definitely working fine up until a few days ago.


It was really bad timing for me, as I was preparing to show off the
system internally for wider adoption.

We enforce the authentification for all routes beside /public some days
ago. But that should have no effect on your interconnect, _if_ you are using
/public.

You need to tell me which requests may hung. Check in src and scheduler logs
in /srv/obs/log/ .



--

Adrian Schroeter
email: adrian@xxxxxxx

SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton, HRB
21284 (AG Nürnberg)

Maxfeldstraße 5
90409 Nürnberg
Germany



< Previous Next >
Follow Ups