Mailinglist Archive: opensuse-buildservice (63 mails)

< Previous Next >
Re: [opensuse-buildservice] All project targets report "repository setup is broken, build not possible" and api.opensuse.org/public is down
On Mon, Jan 25, 2016 at 2:17 AM, Adrian Schröter <adrian@xxxxxxx> wrote:
On Samstag, 23. Januar 2016, 14:53:41 CET wrote Neal Gompa:
Hello,

On Thursday, I set up a new instance of OBS, expecting for it to be as
functional as all the previous ones I had before. However, I wound up
being unable to build anything with it, because all the build targets
don't work. The error it reports is "The repository setup is broken,
build not possible".

After quite a bit of digging, I found out that api.opensuse.org/public
is returning HTTP 404 errors, which I believe is preventing my OBS

You may have not used httpS ? /public should given you a 302 redirection.

Better try something like

https://api.opensuse.org/public/about

instances from configuring and building packages.

I'm running OBS Unstable, but I've also verified the problem with OBS
2.6.7 as well.



The openSUSE.org linker project is configured as such:

<project name="openSUSE.org">
<title>Standard OBS instance at build.opensuse.org</title>
<description>This instance delivers the default build targets for
OBS.</description>
<remoteurl>https://api.opensuse.org/public</remoteurl>
</project>


It is using https, and this is the default configuration that OBS sets
up with. https://api.opensuse.org/public/about also returns a 404
error.



--
真実はいつも一つ!/ Always, there's only one truth!
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups