Mailinglist Archive: opensuse-buildservice (63 mails)

< Previous Next >
[opensuse-buildservice] v4 signs in obs-signd
Hi,
I just learn the hard way that gnupg2 had this change;

--force-v3-sigs
--no-force-v3-sigs
--force-v4-certs
--no-force-v4-certs
These options are obsolete and have no effect since GnuPG 2.1.

The problem is that these options are used by signd perl script from obs-signd.
Those options are silently ignored now. However, when --files-are-digest is
then used it errors with:
"files-are-digests doesn't work with v4 sigs"

Latest working gpg is 2.0.x. If you have your own instance of OBS be careful
when upgrading to not upgrade gpg2.

Does anybody started investigating or even writing support for files-are-digest
for v4 sigs?

--
Miroslav Suchy, RHCA
Red Hat, Senior Software Engineer, #brno, #devexp, #fedora-buildsys
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages