Mailinglist Archive: opensuse-buildservice (96 mails)

< Previous Next >
Re: [opensuse-buildservice] Create Add-On product with OBS: Setup and repos?
Hello all,


I still can't create an addon CD. Neither on our local OBS instance nor on
build.opensuse.org.


In order to rule out a problem with our private OBS instance I tried a
testbuild on
build.opensuse.org, but I'm already stuck when trying to commit the package:

--- snip (osc commit ... (version with --debug below)) ---
user@box:~/tmp/home:tdoerges/TestB> osc commit -m "Initial commit"
Server returned an error: HTTP Error 401: basic auth failed
--- snap ---

Login with a browser via the webinterface works just fine. I've tried both
removing
~/.oscrc and setting a new password via the webinterface.


I'm using the standard OSC 0.152 supplied with openSUSE 13.1.


I'd greatly appreciate any help in resolving either issue
- auth problem with build.opensuse.org
- finding the cause (see below) for this error message
No live log available: remote error: _product Test-Addon-cd-cd-x86_64 no
logfile


Thanks and regards -- Till


--- snip (osc --debug commit ...) ---
user@box:~/tmp/home:tdoerges/TestB> osc --debug commit -v -m "Initial commit"
GET https://build.opensuse.org/source/home:tdoerges
GET https://build.opensuse.org/source/home:tdoerges/TestB?rev=latest
POST
https://build.opensuse.org/source/home:tdoerges/TestB?cmd=getprojectservices
Server returned an error: HTTP Error 401: basic auth failed
Date: Thu, 22 Oct 2015 13:49:54 GMT
Server: Apache/2.2.12 (Linux/SUSE)
Strict-Transport-Security: max-age=31536000
cache-control: no-cache
vary: Accept-Encoding
x-xss-protection: 1; mode=block
www-authenticate: basic realm="API login"
x-opensuse-runtimes:
{"view":0.8557540131732821,"db":0.49792299999999995,"backend":0,"xml":0}
x-request-id: 0b7f10e8-fc49-4ff7-9c1f-ade4a3471c83
x-opensuse-apiversion: 2.6.51.git20151013.08e8db5
x-runtime: 0.007432
x-frame-options: SAMEORIGIN
x-content-type-options: nosniff
x-opensuse-errorcode: anonymous_user
X-Powered-By: Phusion Passenger 5.0.7
Status: 401 Unauthorized
Content-Type: application/xml; charset=utf-8
Connection: close
Transfer-Encoding: chunked
--- snap ---


Am 21.10.2015 um 18:19 schrieb Till Dörges:
Hi Scott, Andreas, Adrian,

thanks for your answers!

Am 20.10.2015 um 19:40 schrieb Scott Bahling:
On Tue, 2015-10-20 at 19:07 +0200, Till Dörges wrote:

I'd like to build an addon CD using a private OBS instance.

<snip>

Pay attention to the project config. Specifically the following
definition:

%if "%_repository" == "images"
Type: kiwi
Repotype: staticlinks
Patterntype: none
%endif
[...]
Substitute: kiwi-packagemanager:instsource kiwi-instsource
cdrkit-cdrtools-compat syslinux kiwi-instsource-plugins-openSUSE-12-1


I did this and things changed. ;-) But somewhere something's still wrong...


If I add an "images" repository with just the openSUSE 13.1 standard
repository for
x86_64:

<repository name="images">
<path project="openSUSE.org:13.1" repository="standard"/>
<arch>x86_64</arch>
</repository>

I get:

nothing provides master-boot-code needed by kiwi

for the package _product:Test-Addon-cd-cd-x86_64


I'm not sure why it does that because the RPM generally is available, however
only as
an i586 RPM. I solved it by adding a repo with a dummy x86_64 RPM which simply
contains a "Provides: master-boot-code", which works fine for a different
instance of
the problem (dependency solving works, right RPM actually get's pulled in).

After having added the 2nd path to the images repository I now get

No live log available: remote error: _product Test-Addon-cd-cd-x86_64 no
logfile

for the package _product:Test-Addon-cd-cd-x86_64


I'm trying this on OBS 2.6.3 on openSUSE 13.1, x86-64.


Regards and TIA -- Till
--
Dipl.-Inform. Till Dörges doerges@xxxxxxxxxxxx
Tel. +49 - 40 - 244 2407 - 14
Fax +49 - 40 - 244 2407 - 24
PRESENSE Technologies GmbH Sachsenstr. 5, D-20097 HH
Geschäftsführer/Managing Directors AG Hamburg, HRB 107844
Till Dörges, Jürgen Sander USt-IdNr.: DE263765024
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups