Mailinglist Archive: opensuse-buildservice (89 mails)

< Previous Next >
Re: [opensuse-buildservice] Removing binaries fail
  • From: Hans-Peter Jansen <hpj@xxxxxxxxx>
  • Date: Thu, 10 Sep 2015 21:22:53 +0200
  • Message-id: <5955505.tQmrIe8I4y@xrated>
On Donnerstag, 10. September 2015 18:38:56 Dominique Leuenberger / DimStar
wrote:
On Thu, 2015-09-10 at 18:31 +0200, Hans-Peter Jansen wrote:
for some reasons, but I not able to resolve, why.

In order to build vdr-plugin-softhddevice, I needed to add ffmpeg
from
multimedia:libs to my project home:frispete:vdr. After a successful
build, I
noticed, that the ffmpeg binaries shouldn't be published, as we all
use the
packman versions, of course.

Diabling the publish flag obviously doesn't cut it after the fact,
but an
attempt of

osc wipebinaries --all home:frispete:vdr ffmpeg

publishing for the package which you want to wipe must be enabled...
otherwise, changes of the package are not published to the repository.

Dear Dominique,

thanks for the answer, but now I'm even more puzzled with the result. When I
entered my workspace, first thing I did was a reload of the 64bit download
page to check the state: nothing changed, still a ffmpeg-2.7.2 and friends
lying around.

Then I read your and Jan's answer, but yours seems to better match my
intentions. Hence, I enabled publishing just to wipe the _package_, and
disabled publishing again. Next I checked the result - but that really puzzled
me - as that operation made a new ffmpeg version (2.8) appear, which means,
that an ffmpeg update was picked up from multimedia:libs and built meanwhile.
The small time window of enable publishing was enough to push it out, and the
wipe - even with publishing enabled - seem to be dysfunctional.

The situation is even uglier now, since there's a version mismatch with the
packman version. Hrmpf.

Pete

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >