Mailinglist Archive: opensuse-buildservice (138 mails)

< Previous Next >
Re: [opensuse-buildservice] Oldest (instead of newest) RPM chosen from update repository
Are you refreshing the primary.xml file you downloaded from the update
repo? As I understand, for update repo¹s you should occasionally download
updated copies and then run obs_admin --rescan-repository on the repp¹s.

On 25/3/15 6:43 am, "Till Dörges" <doerges@xxxxxxxxxxxx> wrote:

Hi,

I've got a private OBS instance running with both the openSUSE 13.1 and a
corresponding Update repository configured.

OBS version is 2.6. All services/daemons are running on a single server
with openSUSE
13.1 (x86_64).

The repositories are local. The 13.1 repo has been copied to the OBS
server. The
13.1-Update repo has been configured as download on demand according to
https://en.opensuse.org/openSUSE:Build_Service_private_instance_boot_strap
ping#Use_Repository_Binary_Download_On_Demand_.28DOD.29


It now seems that OBS uses the *oldest* RPM which it can find in the
update
repository, instead of the latest.


My update repo has the following packages for glibc available:

--- snip ---
.../update/13.1 # find . -iname glibc-2\*
./i686/glibc-2.18-4.15.2.i686.rpm
./i686/glibc-2.18-4.21.1.i686.rpm
./i686/glibc-2.18-4.21.1_4.29.1.i686.drpm
./i686/glibc-2.18-4.29.1.i686.rpm
./i686/glibc-2.18-4.4.1_4.29.1.i686.drpm
./i686/glibc-2.18-4.7.1.i686.rpm
[...]
./i586/glibc-2.18-4.11.1.i586.rpm
./i586/glibc-2.18-4.15.1.i586.rpm
./i586/glibc-2.18-4.21.1.i586.rpm
./i586/glibc-2.18-4.21.1_4.29.1.i586.drpm
./i586/glibc-2.18-4.29.1.i586.rpm
./i586/glibc-2.18-4.4.1_4.29.1.i586.drpm
./i586/glibc-2.18-4.7.1.i586.rpm
[...]
--- snap ---

The distribution repo contains only this:

--- snip ---
.../distribution> find . -iname glibc-2\*
./13.1/repo/oss/suse/i686/glibc-2.18-4.4.1.i686.rpm
./13.1/repo/oss/suse/i586/glibc-2.18-4.4.1.i586.rpm
./13.1/repo/oss/suse/x86_64/glibc-2.18-4.4.1.x86_64.rpm
--- snap ---


If I commit a package with the following BuildRequires it works (i.e.
RPMs are build)
with both the 13.1 and the 13.1-Update repos (expected):

BuildRequires: glibc >= 2.18-4.4

The following does not work with the 13.1 repo but with the 13.1-Update
repo (also
expected):

BuildRequires: glibc >= 2.18-4.7


If the spec file contains

BuildRequires: glibc >= 2.18-4.28

or

BuildRequires: glibc >= 2.18-4.11

it does work with *neither* repo. But if I understand matters correctly
it should
work for the 13.1-Update repo.


Is this a configuration problem? Or perhaps something else?


If more information is needed, I'm happy to provide it.


Regards -- Till
--
Dipl.-Inform. Till Dörges doerges@xxxxxxxxxxxx
Tel. +49 - 40 - 244 2407 - 14
Fax +49 - 40 - 244 2407 - 24
PRESENSE Technologies GmbH Sachsenstr. 5, D-20097 HH
Geschäftsführer/Managing Directors AG Hamburg, HRB 107844
Till Dörges, Jürgen Sander USt-IdNr.: DE263765024
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx



--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References