Mailinglist Archive: opensuse-buildservice (105 mails)

< Previous Next >
Re: [opensuse-buildservice] slightly confused
  • From: Hans Witvliet <suse@xxxxxxxxxxx>
  • Date: Sun, 12 Oct 2014 23:02:04 +0200
  • Message-id: <1413147724.26402.177.camel@orion1>
On Fri, 2014-10-10 at 09:11 +0200, Stephan Kulow wrote:
On 09.10.2014 22:29, Hans Witvliet wrote:
Hi list,

Please bear with me if asking newby questions.

I've been using the results of the OBS for many years, but i founf
myself needing some packages that were not updated for quite some time.

Easiest way might be pinging on factory list, but I presume
doing-it-yourself might be considered a better option. I don't have the
impression anyone else might benefit from it, but when succeeding i will
learn a lot.

My first attempt was branching off an existing (and known working)
package.
To be able to build locally i needed libpcsc-devel, so i branched
security:/chipcard/pcsc-lite.
I defined build-targets OS12.2, OS12.3, OS13.1 OS_factory and SLES11SP3,
which all do exists.
How come that SLES11SP3 failed with "unresolvable" ?
I thought i branched off a working config?


You branched working sources, but to branch off a working config you need
to actually build against security:chipcard's SP3 target not SP3 itself.

Greetings, Stephan
=========================================================================
Thanks all,

At least my first lesson is to try to keep my mail shorter as several
different points were raised.

Let me first focus on following point "working software"
I suppose i got caught in between builds.

Lets take for example the code from security:/chipcard/pcsc-lite.
The code itself is fine, i presume, as it builds in the original
project-directory fine for targets, like:
http://ftp5.gwdg.de/pub/opensuse/repositories/security:/chipcard/openSUSE_Factory/x86_64/

but when looking at:
http://ftp5.gwdg.de/pub/opensuse/repositories/security:/chipcard/SLE_11_SP3/x86_64/

It looks completely different: many packages (not just the mentioned
pcsc_lite) are missing.

When i try to branch it one sees why:
https://build.opensuse.org/package/show/home:testhans/pcsc-lite
It fails for sles11SP3 with "unresolvable" and while hovering overit it
further explains: "nothing provides sysvinit(syslogng)

So obviously, IF there is something wrong with the original specfile,
any branch is doomed to fail also.

I am fully aware that the opensuse-targets all use systemd, while
sles11sp3 still uses system5. Or am i looking in the wrong direction.
(funny thing is, that the spec _seems_ systemd aware: according to the
spec: "Patch0: systemd-service.patch" )


Other point here:
My branch of pcsc-lite builds for OS12.3 ans OS13.1,
even though they are missing on the original package branch

There are still many other questions, but this worries me the most.
specially as lastest build for sles dates from 3-Oct


So who should be notified (no author defined in this spec)?

Hans
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >