Mailinglist Archive: opensuse-buildservice (116 mails)

< Previous Next >
Re: [opensuse-buildservice] Builds not completing
On Wed, Aug 13, 2014 at 11:23:11AM -0700, Smith, Kenneth wrote:
Hello again! Been away for a while. We moved to a new facility and
changed much of our network around, and as a result rebuilt our obs
private installation anew and fresh from the 2.5.4-Build1.4
appliances.

I now have an issue with builds not completing. We have eight workers
happily busy building packages but getting nowhere with them.

Contents of Build Log:
connect to obsmaster:5352: No route to host

It should be trying to connect to obsmaster-int here, not obsmaster.

Some network details: Our OBS server is using two NICs to access two
subnets: one is called obsmaster on the .4 subnet and the other is
obsmaster-int on the .1 subnet. We are reserving the .1 for servers
and using .4 for the "public" interface.

OBS Server:/usr/lib/obs/BSConfig.pm:
reposerver = obsmaster:5252
srcserver = obsmaster:5352
workerreposerver = obsmaster-int:5252
workersrcserver = obsmaster-int:5352

OBS Worker:/etc/sysconfig/obs-server:
OBS_REPO_SERVER = obsmaster-int:5252
OBS_SRC_SERVER = obsmaster-int:5352

The workers talk to obsmaster-int okay, but somewhere along the line
presumably the server is telling them to talk over the public subnet,
to which they have no route.

Is there some configuration detail I am missing, or else some hack to
make this work?

The workers use the data from contained in the jobs created by the
scheduler. So do the jobs in /srv/obs/jobs/<arch> contain the correct
hosts?

Cheers,
Michael.

--
Michael Schroeder mls@xxxxxxx
SUSE LINUX Products GmbH, GF Jeff Hawn, HRB 16746 AG Nuernberg
main(_){while(_=~getchar())putchar(~_-1/(~(_|32)/13*2-11)*13);}
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References