Mailinglist Archive: opensuse-buildservice (111 mails)

< Previous Next >
[opensuse-buildservice] Re: builds failing for 13.1 due to udev
  • From: Andreas Schwab <schwab@xxxxxxxxxxxxxx>
  • Date: Mon, 07 Jul 2014 23:53:29 +0200
  • Message-id: <87oax04yzq.fsf@igel.home>
Mathias Homann <Mathias.Homann@xxxxxxxxxxxx> writes:

Am Freitag, 27. Juni 2014, 09:39:52 schrieb Mathias Homann:

I have a few packages in my home project that fail to build for 13.1 with
the following stuff in the logfiles:

[ 204s] libudev1-208-6.1
########################################
[ 204s] /var/tmp/rpm-tmp.UL5Gsb: line 14: udevadm: command not found
[ 205s] udev-208-6.1
########################################
[ 205s] error: unpacking of archive failed on file
/usr/lib/udev/rules.d/42- usb-hid-pm.rules;53a2f604: cpio: open failed -
Inappropriate ioctl for device [ 205s] error: udev-208-6.1.i586: install
failed

The error message is misleading. The problem is that libmtp9 contains
/lib/udev as a directory, but udev wants to install it as a symlink.
You need to fix the libmtp package to remove that conflict.

The same package builds without error locally... osc build openSUSE_13.1
"just
works".

You probably never tried to build in a clean build root.

Andreas.

--
Andreas Schwab, schwab@xxxxxxxxxxxxxx
GPG Key fingerprint = 58CA 54C7 6D53 942B 1756 01D3 44D5 214B 8276 4ED5
"And now for something completely different."
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References