Mailinglist Archive: opensuse-buildservice (140 mails)

< Previous Next >
Re: [opensuse-buildservice] Gettin x86_64 worker to build armv7l packages
Adrian Schröter - 14:42 24.06.14 wrote:
On Dienstag, 24. Juni 2014, 11:41:59 wrote Michal Hrusecky:
Michal Hrusecky - 7:38 20.06.14 wrote:
Joshua Plautz - 17:40 19.06.14 wrote:
I'm guessing this is the same issue I hit when I upgraded to 2.4. The
openSUSE armv7l prjconfs include a host label requirement but that
wasn't really documented anywhere.

In your buildconfig you probably have something like this if you copied
the openSUSE ARM projects:

Constraint: hostlabel QEMU_ARM

All that you need to do is edit /etc/sysconfig/obs-server on your QEMU
capable workers and add this:


Hmmm, I originally noticed this and removed Constraint: part from my
prjconf. Now I put it back and configured it as you said and still
nothing. In theory the trouble could be that I'm currently running
everything in virtual machine to test the setup and therefore my workers
are configured to use lxc, but that shouldn't be an issue as arm user
emulation can't take advantage of kvm anyway, right?

Ok, so I moved forward towards my goal a little bit, but the path I'm
taking is definitely not the right one.

What I did is that I added armv7l to %cando['x86_64'] in BSCando. And I

That sounds wrong, you should have a

Hostarch: x86_64

defined in prjconf instead.

Hmmm, decided to give it yet another try, thrown away my VM, started
from scratch and now it works. Strange. Don't know what I did wrong
before, but now it works :-)

So it was all some configuration fault somewhere, sorry for the
meaningless noise :-)
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >