Mailinglist Archive: opensuse-buildservice (140 mails)

< Previous Next >
Re: [opensuse-buildservice] Gettin x86_64 worker to build armv7l packages
  • From: Joshua Plautz <jplautz@xxxxxxxx>
  • Date: Thu, 19 Jun 2014 17:40:51 -0500
  • Message-id: <>
I'm guessing this is the same issue I hit when I upgraded to 2.4. The openSUSE armv7l prjconfs include a host label requirement but that wasn't really documented anywhere.

In your buildconfig you probably have something like this if you copied the openSUSE ARM projects:

Constraint: hostlabel QEMU_ARM

All that you need to do is edit /etc/sysconfig/obs-server on your QEMU capable workers and add this:



On 06/19/2014 06:45 AM, Michal Hrusecky wrote:

I'm trying to get my local instance of OBS to compile packages for
Debian/arm. I downloaded the iso, set up the virtual machine,
installed obs there, created local repository, copied prjconf from
build.o.o, copied binaries from Debian repositories and tried building
a test package.

It works and compiles for x86_64 and i586. So far so good. But armv7l is
in scheduled state forever. I tried googling around and I found out,
that I should use the following in prjconf:

%ifarch armv7l armv5el
HostArch: x86_64

Did that, retriggered builds, x86_64 and i586 rebuilt but armv7l it is
still in scheduled state only.

I expect that I will hit another problem with running qemu-user in
Debian afterwards, but that one, I guess I will be able to workaround
somehow. But have no idea how to make my lazy x86_64 virtual machine to
even try building for arm :-)

Any ideas what to try?

To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups