Mailinglist Archive: opensuse-buildservice (140 mails)

< Previous Next >
[opensuse-buildservice] Gettin x86_64 worker to build armv7l packages

I'm trying to get my local instance of OBS to compile packages for
Debian/arm. I downloaded the iso, set up the virtual machine,
installed obs there, created local repository, copied prjconf from
build.o.o, copied binaries from Debian repositories and tried building
a test package.

It works and compiles for x86_64 and i586. So far so good. But armv7l is
in scheduled state forever. I tried googling around and I found out,
that I should use the following in prjconf:

%ifarch armv7l armv5el
HostArch: x86_64

Did that, retriggered builds, x86_64 and i586 rebuilt but armv7l it is
still in scheduled state only.

I expect that I will hit another problem with running qemu-user in
Debian afterwards, but that one, I guess I will be able to workaround
somehow. But have no idea how to make my lazy x86_64 virtual machine to
even try building for arm :-)

Any ideas what to try?
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups