Mailinglist Archive: opensuse-buildservice (166 mails)

< Previous Next >
Re: [opensuse-buildservice] Branched package fails to build without any modifications
On Tue, May 20, 2014 at 01:25:20PM +0200, Joschi Brauchle wrote:
On 05/20/2014 11:09 AM, Adrian Schröter wrote:
On Dienstag, 20. Mai 2014, 10:38:17 wrote Joschi Brauchle:
Hello everyone,

I'm not sure if this is the right email list to ask questions about
building packages on OBS, but I'll try anyway.

I branched the "SSSD" package from the official openSUSE:13.1 repository
into my home repo here:
https://build.opensuse.org/package/show/home:endzone:branches:openSUSE:13.1:Update/sssd195

The package fails to build (error during build section with "xmllint"
failing) although there are no modifications! I am wondering how this
can happen and why did the package build correctly in the original
"openSUSE:13.1" then?

It did for sure :). However, OBS redirects you by default the maintenance
updates we released meantime. It might be that one of these updates
broke it.

You can add another repository to your project not building against
openSUSE:13.1:Update
but against openSUSE:13.1 to verify if that is the case.

Okay, the package builds fine against plain "openSUSE:13.1", hence (afaik)
some other package in ...:Update must break it.

But for me the problem is solved here, thanks!

It is probably libxml2 with that fix:

-------------------------------------------------------------------
Wed May 7 10:48:11 UTC 2014 - vcizek@xxxxxxxx

- fix for CVE-2014-0191 (bnc#876652)
* libxml2: external parameter entity loaded when entity
substitution is disabled
* added libxml2-CVE-2014-0191.patch

Ciao, Marcus
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >