Mailinglist Archive: opensuse-buildservice (83 mails)

< Previous Next >
[opensuse-buildservice] all aarch64 and armv6l builds broken
Hi,

since one or two days aarch64 and armv6l does not work anymore:


$ osc rbl home:rudi_m:devel-snap/atem openSUSE_13.1_ports aarch64

[ 0s] Using BUILD_ROOT=/var/cache/obs/worker/root_4/.mount
[ 0s] Using BUILD_ARCH=aarch64
[ 0s] Doing kvm build in /var/cache/obs/worker/root_4/root
[ 0s]
[ 0s]
[ 0s] build79 started "build atem.spec" at Wed Apr 2 11:50:56 UTC
2014.
[ 0s]
[ 0s] Building atem for project 'home:rudi_m:devel-snap'
repository 'openSUSE_13.1_ports' arch 'aarch64'
srcmd5 'ebddba094554785b2948d1bd5309298a'
[ 0s]
[ 0s] processing
recipe /var/cache/obs/worker/root_4/.build-srcdir/atem.spec ...
[ 0s] running changelog2spec --target
rpm --file /var/cache/obs/worker/root_4/.build-srcdir/atem.spec
[ 0s]
init_buildsystem --configdir /var/run/obs/worker/4/build/configs --cachedir
/var/cache/build --prepare --clean --rpmlist
/var/cache/obs/worker/root_4/.build.rpmlist
/var/cache/obs/worker/root_4/.build-srcdir/atem.spec
build rpmlint-Factory ...
[ 1s] [1/30] preinstalling filesystem...
[ 1s] [2/30] preinstalling glibc...
[ 1s] [3/30] preinstalling fillup...
[ 1s] [4/30] preinstalling libattr1...
[ 1s] [5/30] preinstalling libbz2-1...
[ 1s] [6/30] preinstalling libcap2...
[ 1s] [7/30] preinstalling libelf1...
[ 1s] [8/30] preinstalling libgcc_s1...
[ 1s] [9/30] preinstalling liblua5_1...
[ 1s] [10/30] preinstalling liblzma5...
[ 1s] [11/30] preinstalling libpcre1...
[ 1s] [12/30] preinstalling libpopt0...
[ 1s] [13/30] preinstalling libz1...
[ 1s] [14/30] preinstalling attr...
[ 1s] [15/30] preinstalling libacl1...
[ 1s] [16/30] preinstalling libncurses5...
[ 1s] [17/30] preinstalling libselinux1...
[ 1s] [18/30] preinstalling libreadline6...
[ 1s] [19/30] preinstalling bash...
[ 1s] [20/30] preinstalling qemu-linux-aarch64...
[ 2s] [21/30] preinstalling diffutils...
[ 2s] [22/30] preinstalling m4...
[ 2s] [23/30] preinstalling sed...
[ 2s] [24/30] preinstalling tar...
[ 2s] [25/30] preinstalling grep...
[ 2s] [26/30] preinstalling coreutils...
[ 2s] [27/30] preinstalling permissions...
[ 2s] [28/30] preinstalling aaa_base...
[ 2s] [29/30] preinstalling rpm...
[ 2s] [30/30] preinstalling pam...
[ 2s]
[ 2s] [1/8] preinstalling libdb-4_8...
[ 2s] [2/8] preinstalling libsepol1...
[ 2s] [3/8] preinstalling libuuid1...
[ 2s] [4/8] preinstalling net-tools...
[ 2s] [5/8] preinstalling perl-base...
[ 2s] [6/8] preinstalling libblkid1...
[ 2s] [7/8] preinstalling libmount1...
[ 2s] [8/8] preinstalling util-linux...
[ 2s] copying packages...
[ 3s] reordering...cycle: libcrack2 -> cracklib
[ 3s] breaking dependency libcrack2 -> cracklib
[ 3s] done
[ 3s] booting kvm...
[ 3s] /usr/bin/qemu-kvm -no-reboot -nographic -vga none -net
none -cpu
host -mem-path /hugetlbfs -kernel /boot/vmlinuz -initrd /boot/initrd -append
root=/dev/disk/by-id/virtio-0 panic=1 quiet no-kvmclock nmi_watchdog=0
rw rd.driver.pre=binfmt_misc elevator=noop console=ttyS0
init=/.build/build -m 10240 -drive
file=/var/cache/obs/worker/root_4/root,if=none,id=disk,serial=0,cache=unsafe
-device
virtio-blk-pci,drive=disk -drive
file=/var/cache/obs/worker/root_4/swap,if=none,id=swap,serial=1,cache=unsafe
-device
virtio-blk-pci,drive=swap -smp 3
[ 5s] FATAL: Module kqemu not found.
[ 5s] FATAL: Module ext2 not found.
[ 5s] FATAL: Module ext3 not found.
[ 6s] Waiting for device /dev/disk/by-id/virtio-0 to appear: ok
[ 6s] fsck from util-linux 2.23.2
[ 6s] [/sbin/fsck.ext4 (1) -- /] fsck.ext4 -a /dev/vda
[ 6s] /dev/vda: clean, 3091/1313760 files, 177312/5248000 blocks
[ 6s] fsck succeeded. Mounting root device read-write.
[ 6s] Mounting root /dev/disk/by-id/virtio-0
[ 6s] mount -o rw,defaults -t ext4 /dev/disk/by-id/virtio-0 /root
[ 6s] replacing /etc/mtab with symlink to /proc/self/mounts
[ 6s] run-init: /.build/build: Exec format error
[ 16s] [ 10.853722] Kernel panic - not syncing: Attempted to kill
init! exitcode=0x00000100
[ 16s] [ 10.853722]
[ 16s] [ 10.854483] CPU: 0 PID: 1 Comm: run-init Not tainted
3.11.6-4-default #1
[ 16s] [ 10.855041] Hardware name: Bochs Bochs, BIOS Bochs
01/01/2011
[ 16s] [ 10.855523] ffff880291ccbed8 ffffffff81560e30
ffffffff817dc0a8 ffffffff8155d0ff
[ 16s] [ 10.856196] 0000000000000010 ffff880291ccbee8
ffff880291ccbe88 ffffffff811090e2
[ 16s] [ 10.856858] 0000000000000100 ffff880291cc83f0
0000000000000037 ffffffff81e71900
[ 16s] [ 10.857394] Call Trace:
[ 16s] [ 10.857394] [<ffffffff81004868>] dump_trace+0x78/0x2c0
[ 16s] [ 10.857394] [<ffffffff81004b3f>]
show_stack_log_lvl+0x8f/0x170
[ 16s] [ 10.857394] [<ffffffff81005e0c>] show_stack+0x1c/0x50
[ 16s] [ 10.857394] [<ffffffff81560e30>] dump_stack+0x41/0x51
[ 16s] [ 10.857394] [<ffffffff8155d0ff>] panic+0xc3/0x1d2
[ 16s] [ 10.857394] [<ffffffff81052488>] do_exit+0x938/0xa50
[ 16s] [ 10.857394] [<ffffffff81052604>] do_group_exit+0x34/0xa0
[ 16s] [ 10.857394] [<ffffffff8105267b>] SyS_exit_group+0xb/0x10
[ 16s] [ 10.857394] [<ffffffff8156eeed>]
system_call_fastpath+0x1a/0x1f
[ 16s] [ 10.857394] [<00007f254d8f2961>] 0x7f254d8f2960
[ 17s] [ 10.857394] Rebooting in 1 seconds..No buildstatus set,
either the base system is broken (glibc/bash/perl)
[ 17s] or the build host has a kernel or hardware problem...


cu,
Rudi
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups