Mailinglist Archive: opensuse-buildservice (83 mails)

< Previous Next >
[opensuse-buildservice] Building of Debian packages does not install dependencies properly anymore
  • From: Timotheus Pokorra <timotheus@xxxxxxxxxx>
  • Date: Tue, 1 Apr 2014 15:04:23 +0200
  • Message-id: <CAJ0=nQd+7k5FRvFi5d8-rzEqdVtis_CrajrApb_TAJUg0WNp_A@mail.gmail.com>
Hello,

I noticed today that all my Debian packages (and Ubuntu packages as
well) don't build anymore.
They used to build fine. I tried with packages that I did not change at all.

This is the problem, see eg:
https://build.opensuse.org/package/live_build_log/home:tpokorra:kontocheck/kontocheck/Debian_7.0/i586
fails after triggering a rebuild.

compare this with the version that built fine 27 days ago:
https://build.opensuse.org/package/live_build_log/home:tpokorra:kontocheck/kontocheck/Debian_7.0/x86_64

There are problems like this:

[ 100s] [171/178] installing debhelper
[ 100s] dpkg: debhelper: dependency problems, but configuring anyway
as you requested:
[ 100s] debhelper depends on perl; however:
[ 100s] Package perl is not installed.
[ 100s] debhelper depends on file (>= 3.23); however:
[ 100s] Package file is not installed.
[ 100s] debhelper depends on dpkg (>= 1.16.2); however:
[ 100s] Package dpkg is not installed.
[ 100s] debhelper depends on dpkg-dev (>= 1.16.2); however:
[ 100s] Package dpkg-dev is not installed.
[ 100s] debhelper depends on binutils; however:
[ 100s] Package binutils is not installed.
[ 100s] debhelper depends on man-db (>= 2.5.1-1); however:
[ 100s] Package man-db is not installed.

All dependancies used to be installed.

In the end, the build fails:

[ 112s] dpkg-checkbuilddeps: Unmet build dependencies:
build-essential:native make gcc
[ 112s] dpkg-buildpackage: warning: build dependencies/conflicts
unsatisfied; aborting

Any ideas?

Thanks,
Timotheus
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups