Mailinglist Archive: opensuse-buildservice (145 mails)

< Previous Next >
[opensuse-buildservice] Re: obs build triggers
someone remove post-build-checks package from
devel:languages:ruby:extensions which triggers rebuilding of SLE
packages for older distros in this project, don't know if this was
related to my mail, but hey ... thanks .... :)

On Sun, Oct 13, 2013 at 10:00 AM, Michal Šebeň <mseben@xxxxxxxxx> wrote:
Hi all,

looks like obs doesn't rebuild packages when their required dependency
packages are disabled, for easier understanding I created 2 dummy
packages in my home :
https://build.opensuse.org/project/show/home:mseben:dependency_issue

Check the package with name dummy (with BuildRequires vim) it's in
"unresolvable" state :
nothings provides noneexistent-dependency needed by vim

problem is that I already disabled build/publish/useforbuild for this
testing vim package with dependency on "nonexistent-dependency",
however this disable action doesn't trigger rebuilding of package
called dummy

similar real world example is package
devel:languages:ruby:extensions/post-build-checks and its deps on
aaa_base-malloccheck - this deps isn't fulfilled on older distros
(which leads to chain of failing builds for them) and I want to just
disable building of this package only for these older distros in order
to fix builds for them
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References