Mailinglist Archive: opensuse-buildservice (247 mails)

< Previous Next >
[opensuse-buildservice] Debian 7/Ubuntu >= 12: unmet dependency libjpeg62-dev
  • From: Claudio Freire <klaussfreire@xxxxxxxxx>
  • Date: Wed, 5 Jun 2013 16:20:02 -0300
  • Message-id: <CAGTBQpaTaLB8cLKHHhuE7fHy-1sMnrwfVTO_uviPGuuJgO=Dww@mail.gmail.com>
I'm getting this weird error[0] for both Debian 7.0 and Ubuntus >=
12.04, and I'm a bit at a loss:

dpkg-checkbuilddeps: Unmet build dependencies: libjpeg62-dev

Thing is, ubuntus used to work before, but a rebuild broke them, so
I'm suspecting some project config snafu (either mine, or the
Ubuntu's). My project config only has these two lines:

Prefer: libsvga1
Prefer: libjack-dev

Both seem unrelated. I did try Prefer: libjpeg8-dev, doesn't seem to
change anything. Adding Prefer: libjpeg62-dev, I didn't try with the
prefer but by specifically requesting libjpeg62-dev in the dsc, and it
fixes the ubuntus, but not Debian.

In any case, while the ubuntus are strange because they used to work,
Debian 7.0 is more puzzling still: it doesn't even have libjpeg62, yet
something is asking for it. I checked my dsc[1] repeatedly, and unless
it's very indirect, I don't think it's being requested there. And if
it were, why isn't it being installed or reported as unresolvable?

Any clues from the community?

[0]
https://build.opensuse.org/package/live_build_log?arch=x86_64&package=vegastrike&project=home%3Aklaussfreire%3Adebian&repository=Debian_7.0
[1]
https://build.opensuse.org/package/view_file?expand=1&file=vegastrike.dsc&package=vegastrike&project=home%3Aklaussfreire%3Adebian
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups