Mailinglist Archive: opensuse-buildservice (209 mails)

< Previous Next >
Re: [opensuse-buildservice] OBS ignoring entires in %files?
On Friday 17 May 2013 15:27:47 Andreas Jaeger wrote:
On 05/17/2013 03:22 PM, Shawn W Dunn wrote:
On Friday 17 May 2013 15:17:54 you wrote:
On Fri, May 17, 2013 at 06:02:05AM -0700, Shawn W Dunn wrote:
So I've got a package put together devel:cloverleaf:Consort
consort-panel,
and I'm ending up with what appears to be rpmbuild ignoring the %files
section for the consort-panel.*.rpm package, and I have been bashing my
head against my desk since last night trying to figure out why. I
don't see any issues with the .spec file, but maybe I'm missing
something.

I've tried using hardlinks (/usr/share instead of %{_datadir}, for
instance} but nothing seems to be making a difference.

I'd be tickled pink if somebody could have a look at that specfile and
tell me what I've got fscked up.....

I think you need to specify

BuildRoot: %{_tmppath}/%{name}-%{version}-build

In the header.

Ciao, Marcus

Nope, just tried that, still getting the same "Installed but Unpackaged"
error...

Please add that line to the spec file and let us check the results
again. I guess it will look different - and then we might be able to
help better ;)

Andreas

Done, OBS is attempting a build right now....
< Previous Next >