Mailinglist Archive: opensuse-buildservice (209 mails)

< Previous Next >
Re: [opensuse-buildservice] RHEL 6.x in OBS 2.4 Build fails
Hi Adrian,

On Wed, 08 May 2013 13:16:09 +0200
Adrian Schröter <adrian@xxxxxxx> wrote:

On Mittwoch, 8. Mai 2013, 07:54:42 wrote Adrian Schröter:
On Dienstag, 7. Mai 2013, 19:01:01 wrote Philipp Seiler:
Hi,

On Tue, 07 May 2013 09:44:08 +0200
Adrian Schröter <adrian@xxxxxxx> wrote:

On Montag, 6. Mai 2013, 21:41:14 wrote Philipp Seiler:
Hi,

I have another problem with OBS.
Everything is running fine except the Builds for RHEL 6.3 and
6.4. All other distributions (openSUSE 12.2, Fedora 17 and
Debian6) I configured in my OBS instance build well.

I use the same prjconf as in the SUSE OBS and the packages
from the RHEL6.x install DVDs. It seems like there is a
problem when initializing the RPM database in the buildroot
of the package. I googled the error message but I haven't
found something with the obs.

If I run a localbuild on my workstation the package builds
well. Also on a running 2.3 instance.
What am I doing wrong?

This is the error message:
[...]

[ 12s] [47/49] preinstalling rpm...
[ 12s] [48/49] preinstalling policycoreutils...
[ 19s] [49/49] preinstalling rpm-libs...
[ 22s]
[ 22s] initializing rpm db...
[ 23s] error: cannot open Name index using db3 - No such
file or directory (2)

well, something is missing so rpm can not operate. Since it
works on our instance, you may want to compare esp prjconf.
Esp. Preinstall, Order and Runscripts rules.

The prjconf is exact the same as in the SUSE OBS.
I also copied the rhel rpms with "obs_mirror_project" for testing
purposes. This ends in the same error.

Otherwise you need to jump in and trace/debug why rpm is not
working.


I found out that the File "Name" (perhaps more) in the obs
changeroot directory /var/lib/rpm/ is broken, when installing the
base system. On all other distributions I build, it's correct.
The difference between my setup and the SUSE OBS is the type of
the worker. I'm using a changeroot worker and the SUSE OBS is
running kvm vms!? The error happens in the preinstall section of
the build process but this part is missing logically in the SUSE
OBS because of the image which boots with the base system. I
reproduced the error on another OBS with changeroot worker.

Can somebody give me a hint how to debug this?

In general, copy you debug tools inside, chroot and call rpm db
initilization manually.

However, in this case, you can be lucky that Martin Mohring found
out that our latest build script breaks old RHEL builds due to this
commit:

1a3df32a47cf3f7adf15439a7cf0ed9bc7f4db53

So, you can revert it, or install the official stable build package
from OBS:Server:2.4 to avoid this error.

Michael fixed it and new "build" versions are building in
openSUSE:Tools and OBS:Server:Unstable now.

We will update OBS:Server:2.4 later.

I'll test and report it.
I also successully built packages with build version 20130308 (revision
30 in OBS:Server:2.4)

Thank you very much for your help.

Regards,
Philipp

--
Philipp Seiler
Linux Consultant
Tel.: +49-175 2958714
Mail: seiler@xxxxxxxxxxxxx GPG Key: 0x75911461

B1 Systems GmbH
Osterfeldstraße 7 / 85088 Vohburg / http://www.b1-systems.de
GF: Ralph Dehner / Unternehmenssitz: Vohburg / AG: Ingolstadt,HRB 3537
< Previous Next >
Follow Ups