Mailinglist Archive: opensuse-buildservice (209 mails)

< Previous Next >
Re: [opensuse-buildservice] RHEL 6.x in OBS 2.4 Build fails

On Tue, 07 May 2013 09:44:08 +0200
Adrian Schröter <adrian@xxxxxxx> wrote:

On Montag, 6. Mai 2013, 21:41:14 wrote Philipp Seiler:

I have another problem with OBS.
Everything is running fine except the Builds for RHEL 6.3 and 6.4.
All other distributions (openSUSE 12.2, Fedora 17 and Debian6) I
configured in my OBS instance build well.

I use the same prjconf as in the SUSE OBS and the packages from the
RHEL6.x install DVDs. It seems like there is a problem when
initializing the RPM database in the buildroot of the package. I
googled the error message but I haven't found something with the

If I run a localbuild on my workstation the package builds well.
Also on a running 2.3 instance.
What am I doing wrong?

This is the error message:

[ 12s] [47/49] preinstalling rpm...
[ 12s] [48/49] preinstalling policycoreutils...
[ 19s] [49/49] preinstalling rpm-libs...
[ 22s]
[ 22s] initializing rpm db...
[ 23s] error: cannot open Name index using db3 - No such file or
directory (2)

well, something is missing so rpm can not operate. Since it works on
our instance, you may want to compare esp prjconf. Esp. Preinstall,
Order and Runscripts rules.

The prjconf is exact the same as in the SUSE OBS.
I also copied the rhel rpms with "obs_mirror_project" for testing
purposes. This ends in the same error.

Otherwise you need to jump in and trace/debug why rpm is not working.

I found out that the File "Name" (perhaps more) in the obs changeroot
directory /var/lib/rpm/ is broken, when installing the base system. On
all other distributions I build, it's correct. The difference between my
setup and the SUSE OBS is the type of the worker. I'm using a changeroot
worker and the SUSE OBS is running kvm vms!? The error happens in the
preinstall section of the build process but this part is missing
logically in the SUSE OBS because of the image which boots with the
base system. I reproduced the error on another OBS with changeroot

Can somebody give me a hint how to debug this?
How can I call the build process manually (with debug paramaters,
strace or something). I don't mean the manual executing of bs_server
(already did that), but for example to trace the output of the command


Philipp Seiler
Linux Consultant
Tel.: +49-175 2958714
Mail: seiler@xxxxxxxxxxxxx GPG Key: 0x75911461

B1 Systems GmbH
Osterfeldstraße 7 / 85088 Vohburg /
GF: Ralph Dehner / Unternehmenssitz: Vohburg / AG: Ingolstadt,HRB 3537
< Previous Next >
Follow Ups