Mailinglist Archive: opensuse-buildservice (131 mails)

< Previous Next >
[opensuse-buildservice] KIWI image build on OBS creates endless loop
Hello,

i'm trying to build a small image using kiwi as a base for a later project,
i created .kiwi files for each image (net,iso,usb,vmx).

The usb & vmx build is running into an endless loop, maybe someone can have
a look what the problem may be and can point me to the right direction to
fix this.

Project: home:netmax:playground:kiwi
Package: mini-image-usb & mini-image-vmx

Thats the part which is looping:

Feb-28 20:11:32 &lt;1&gt; : Increasing disk size by 10M to: 4283M
[ 986s] .
[ 986s] Feb-28 20:11:32 &lt;1&gt; : EXEC [qemu-img create
/usr/src/packages/KIWI-vmx/vmx/mini-image.x86_64-0.0.1.raw 4283M 2&gt;&amp;1]
[ 986s] Feb-28 20:11:33 &lt;1&gt; : EXEC [/sbin/losetup -f --show
/usr/src/packages/KIWI-vmx/vmx/mini-image.x86_64-0.0.1.raw 2&gt;&amp;1]
[ 986s] Feb-28 20:11:33 &lt;1&gt; : EXEC [bash -c "PATH=$PATH:/sbin which
parted" 2&gt;&amp;1]
[ 986s] Feb-28 20:11:33 &lt;1&gt; : EXEC [bash -c "PATH=$PATH:/sbin which
parted" 2&gt;&amp;1]
[ 986s] Feb-28 20:11:33 &lt;1&gt; : EXEC [dd if=/dev/zero of=/dev/loop0 bs=512
count=1 2&gt;&amp;1]
[ 986s] Feb-28 20:11:33 &lt;1&gt; : EXEC [/usr/sbin/parted -s /dev/loop0
mklabel msdos 2&gt;&amp;1]
[ 987s] Feb-28 20:11:33 &lt;1&gt; : EXEC [/usr/sbin/parted -m /dev/loop0 unit
s print | head -n 3 |
tail -n 1 | cut -f2 -d:]
[ 987s] Feb-28 20:11:33 &lt;1&gt; : Disk Sector count is: 8771583
[ 987s] Feb-28 20:11:33 &lt;1&gt; : PARTED input: /dev/loop0 [mkpart primary
2048 8771583]
[ 987s] Feb-28 20:11:33 &lt;1&gt; : EXEC [/usr/sbin/parted -s /dev/loop0 unit
s mkpart primary 2048
8771583 2&gt;&amp;1]
[ 987s] Feb-28 20:11:33 &lt;1&gt; : PARTED input: /dev/loop0 [set 1 boot on]
[ 987s] Feb-28 20:11:33 &lt;1&gt; : EXEC [/usr/sbin/parted -s /dev/loop0 unit
s set 1 boot on
2&gt;&amp;1]
[ 987s] Feb-28 20:11:33 &lt;1&gt; : EXEC [/sbin/kpartx -a /dev/loop0
2&gt;&amp;1]
[ 987s] Use of uninitialized value $pdev in concatenation (.) or string at
/usr/share/kiwi/modules/KIWIBoot.pm line 5872.
[ 987s] Feb-28 20:11:33 &lt;1&gt; : EXEC [blockdev --getsize64 2&gt;&amp;1]
[ 988s] Feb-28 20:11:34 &lt;1&gt; : EXEC [sync]
[ 988s] Feb-28 20:11:34 &lt;1&gt; : EXEC [sync]
[ 988s] Feb-28 20:11:34 &lt;1&gt; : EXEC [kpartx -d /dev/loop0 2&gt;&amp;1]
[ 988s] Feb-28 20:11:34 &lt;1&gt; : EXEC [losetup -d /dev/loop0 2&gt;&amp;1]


Regards,
Carsten

< Previous Next >
List Navigation
This Thread
  • No further messages