Mailinglist Archive: opensuse-buildservice (140 mails)

< Previous Next >
[opensuse-buildservice] database migrate error
HI All

I update my OBS from 2.1 to 2.3 following the README.UPDATES guideline in
obs-api package, but I have a prolem.

When I execute this command --- ---" RAILS_ENV="production" rake
db:migrate" in /srv/www/obs/api directory , I got the following error log:
<<<<<<<<<<<<<<

WARNING: The database is inconsistent, some FOREIGN KEYs (aka CONSTRAINTS)
can not be added!
please run script/check_database script to fix the data.
rake aborted!


Any body can help me ? Thanks very much!



-----
Go OBS
--
View this message in context:
http://opensuse.14.n6.nabble.com/database-migrate-error-tp4970863.html
Sent from the opensuse-buildservice mailing list archive at Nabble.com.
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups