Mailinglist Archive: opensuse-buildservice (244 mails)

< Previous Next >
Re: [opensuse-buildservice] unresolvable errors while building packages for RHEL_6
On 06/21/2012 04:27 PM, Adrian Schröter wrote:
Am Donnerstag, 21. Juni 2012, 07:31:42 schrieb S. Nandhini:
Hi,

How can the unresolvable errors be fixed? When I try building lvm rpm for
RHEL_6 (x86_64) it reports the following error
Nothing provides corosynclib-devel >= 1.2.0-1, openaislib-devel >=
1.1.1-1, clusterlib-devel >= 3.0.6-1
Similarly for unixODBC rpm on RHEL_6 x86_64 I get the following error.
Nothing provides libtool-ltdl-devel

Is there a way to add customized repository for individual projects?

That rpms are most likely not part of official RedHat shipment and only
available via RHN. However we can not import rpms from there for
legal reasons. The only way is either to import a source rpm
and build it yourself or to build against a compatible RedHat clone
instead.

FWIW, corosync 1.4.3 and openais 1.1.4 are building for RHEL 6 in
network:ha-clustering, so if you build against that repo, it'll
hopefully get you most of the way there. I can't help with
clusterlib-devel though. You'll probably need to import the SRPM and
build that yourself as Adrian suggested.

Note: the RHEL, Fedora and CentOS builds of corosync and openais in
network:ha-clustering are built straight from the latest upstream source
and spec files. This may or may not be exactly the same as what RH do
for their builds (i.e., I don't know what if any RH specific tweaks they
apply), and I haven't tried actually using those builds myself.

HTH,

Tim
--
Tim Serong
Senior Clustering Engineer
SUSE
tserong@xxxxxxxx
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >