Mailinglist Archive: opensuse-buildservice (244 mails)

< Previous Next >
Re: [opensuse-buildservice] Re: %goprep macro not found by rpm-build
  • From: Michał Papis <mpapis@xxxxxxxxx>
  • Date: Mon, 11 Jun 2012 17:40:18 +0200
  • Message-id: <>
I gave it another try on opensuse factory and those macros worked.

On Fri, Jun 8, 2012 at 5:19 PM, Graham Anderson <graham@xxxxxxxxxx> wrote:
On Friday 08 Jun 2012 00:11:27 Malcolm wrote:
On Fri, 8 Jun 2012 06:30:10 +0200

Michał Papis <mpapis@xxxxxxxxx> wrote:
I have created build script home:mpapis/sm-json and it fails, here is
log of it's build

I tried to google for this/similar error, and it looks like there is
no %goprep macro, but I have no clue why it would be missing, I have
searched for similar packages spec and I think I did everything
properly - but still the error happens in both building via service
and locally. after commenting the %goprep line it fails on %gobuild


Have a look at /etc/rpm/macros.go file to see
what macros exist....

That's a bit out of date, see:
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >