Mailinglist Archive: opensuse-buildservice (259 mails)

< Previous Next >
RE: [opensuse-buildservice] Fedora 17 added, new build package required
  • From: Frank Lichtenheld <Frank.Lichtenheld@xxxxxxxxxx>
  • Date: Wed, 30 May 2012 18:58:02 +0000
  • Message-id: <9C7389C8A12BF14693BB775D010D7BF303BD1B@de-wie-exch3b.green.sophos>
-----Original Message-----
From: Adrian Schröter [mailto:adrian@xxxxxxx]
Sent: Wednesday, May 30, 2012 8:26 PM
To: opensuse-buildservice@xxxxxxxxxxxx
Cc: Frank Lichtenheld
Subject: Re: [opensuse-buildservice] Fedora 17 added, new build package
required

Am Mittwoch, 30. Mai 2012, 16:21:07 schrieb Frank Lichtenheld:
I added this to my Home project (home:flichtenheld).
I had some issues with kmod which seems to be a module-init-tools
replacement (Obsoletes: module-init-tools):
* I needed to add "Prefer: kmod" since some of the programs
complained that they couldn't decide between kmod and module-init-tools
(for dependency module-init-tools)
* But this then creates a file conflict since module-init-tools is
listed in "Support"

I would suggest adding the Prefer and replacing module-init-tools in
Support with kmod.

Can you test this in your prjconf first by adding

Prefer: kmod
Support: -module-init-tools

? The second line will remove the support state from Fedora:17 prjconf
again in your project.

Hmm, that doesn't seem to work, it still wants to install module-init-tools.
Any ideas why?

Gruesse,
Frank
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups