Mailinglist Archive: opensuse-buildservice (241 mails)

< Previous Next >
Re: [opensuse-buildservice] 2 versions of a package in a repo
On 04/25/2012 07:37 PM, Darin Perusich wrote:
Hello,

I'm building a package that requires perl-Net-Whois-RIPE 1.31 or OLDER
and I'm wondering what's the best approach to go about adding that
version to a repo, devel:lang:perl repo in this case, which already
includes version 2.00009? Should I repackage it changing the name to
perl-Net-Whois-RIPE1 and include a Conflicts for version -gt 2? Or
change nothing so they sit alongside each other in to repo but set the
Require for my package to version 1.31?

Thanks!

--
Later,
Darin
Hi Darin,

A working solution for this would be to give a different name to the old package (perl-Net-Whois-RIPE1)
and use this in your Require statement.

--
Angelos Tzotsos
Remote Sensing Laboratory
National Technical University of Athens
http://users.ntua.gr/tzotsos

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References