Mailinglist Archive: opensuse-buildservice (214 mails)

< Previous Next >
Re: [opensuse-buildservice] test of obs-server.x86_64-2.2.116-Build1.2.raw in a update from version 2.1
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Wed, 01 Feb 2012 10:31:33 +0100
  • Message-id: <5088737.Sqme4bKxnS@scherben>

JFYI, the current appliances are using sysvinit now and that solves most of
the problems.

I hope the database trashing will not happen again :(


Am Dienstag, 31. Januar 2012, 01:59:52 schrieb Karsten Keil:

I want share my expirence during a update of a test install from image
obs-server.x86_64-2.1.16-Build1.6.raw.bz2 to

It was a more or less standard setup following the howto on a x86_64
physical host, booted from USB stick and have a LVM setup for the storage:

pingi8:/usr/lib/obs/server # ll /dev/OBS/
total 0
drwxr-xr-x 2 root root 240 Jan 30 10:13 .
drwxr-xr-x 22 root root 4560 Jan 30 10:13 ..
lrwxrwxrwx 1 root root 7 Jan 30 10:13 cache -> ../dm-1
lrwxrwxrwx 1 root root 7 Jan 30 10:13 server -> ../dm-2
lrwxrwxrwx 1 root root 7 Jan 30 10:13 worker_root_1 -> ../dm-3
lrwxrwxrwx 1 root root 7 Jan 30 10:13 worker_root_2 -> ../dm-4
lrwxrwxrwx 1 root root 7 Jan 30 10:13 worker_root_3 -> ../dm-5
lrwxrwxrwx 1 root root 7 Jan 30 10:13 worker_root_4 -> ../dm-6
lrwxrwxrwx 1 root root 7 Jan 30 10:13 worker_swap_1 -> ../dm-7
lrwxrwxrwx 1 root root 7 Jan 30 10:13 worker_swap_2 -> ../dm-8
lrwxrwxrwx 1 root root 7 Jan 30 10:13 worker_swap_3 -> ../dm-9
lrwxrwxrwx 1 root root 8 Jan 30 10:13 worker_swap_4 -> ../dm-10

Under 2.1 a small local project was copied from OBS and setuped
for local build, for 11.4 and 12.1 (32 and 64 bit) and OBS remote link (to
2.1 was running fine, every package did build.
Then I replaced the 2.1.16 USB Stick whith the 2.2.116 version.
I did this after a full backup and a clean shutdown.
First boot die crash the MySQL database completely during the
MySQL update process. The database did not longer work and could not be
repaired (BUG 743697 was submitted).

Later I restored the database backup on an other 12.1 machine and did the
update manually - without any error. So it looks like that if the update
is running on boot time something goes wrong (I did repeat it 3 times).

Then I copied the updated data base to the target machine again and did
the database migration manually - also without any error.

After reboot MySQL was not running, because it did start before
the /obs directory was mounted - fixed with
Required-Start: $network $remote_fs obsstoragesetup
in the mysql startscript and insserv.
obsstoragesetup did not mount /dev/OBS/cache, moved the mount in the
startscript before the worker setups.

Then apache did start before MYSQL was started, because it was in
systemd defined as service. Deleted apache2.service file, now apache2
starts as expected after the required services are running.

Still wrong rights on many files under /obs (because of changed UID/GID
values, repaired with
chown -R obsrun:obsrun /obs/*
chown -R mysql:mysql /obs/MySQL

No access to http://server:82 Error 403 - link not allowed, because
root dir is /srv/obs/repos which is symlinked to /obs/repos.
I tried option FollowSymLinks in the *82 vhost config in
/etc/apache2/vhosts.d/obs.conf and did a restart - still not working.
Then I changed the root dir to /obs/repos in /etc/apache2/vhosts.d/obs.conf
- works, now I have access to the repos again and also zypper works with the
test project.
Main webinterface https://server also works, but builds did not.
Also montitor shows, that the schedulers are not running, after
rcobsscheduler start the processes seems to start and ps ax show them for
3-5 sec, then they die. Logfile looks like:,
last lines are:

fetching remote project data for
fetching remote project data for
sorting projects and repositories...
setting up watcher for
exiting (with complete info)...

Even reboot or several restarts of rcobsscheduler did not start it.
For further debugging I started it with
cd /usr/lib/obs/server
strace ./bs_sched x86_64

and it run normally, also the web monitor changed from red to green, and
builds are running now. I stopped the strace and did run rcobsserver start
again - now also this works for x86_64 as it should !??? - i586 still not
runing (did die after few secs). Repeated the same procedure
for i586 without strace.
cd /usr/lib/obs/server
./bs_sched i586

also this does work now and the i586 builds also succeeded.

Now the 2.2.116 apliance seems to run just fine :-)

Maybe this helps to find the remaining problems, if you want some
logfiles request it.

Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx

To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups