Mailinglist Archive: opensuse-buildservice (162 mails)

< Previous Next >
[opensuse-buildservice] Dependency resolution prefers package names rather than "provides"?
  • From: Cristian Morales Vega <cmorve69@xxxxxxxx>
  • Date: Sun, 15 Jan 2012 11:31:25 +0000
  • Message-id: <CAOWQn3TULN89L6j03MzmKW=xOgYXpJVZNFn2sHKeQbgMiV0dog@mail.gmail.com>
With the OBS down I can't give any example now. But if there is
packageA-devel in openSUSE:12.1 and in the devel project it is renamed
to stillpackageA-devel, the other packages in that devel project that
require "packageA-devel" seem to prefer packageA-devel to
stillpackageA-devel. stillpackageA-devel provides "packageA-devel =
<new_version>" and obsoletes "packageA-devel < <new_version>". Is this
expected?

Usually what happens is that the devel project requires the exact
version of "packageA" and the OBS gives an "unresolvable" state
because it can't find "packageA = <old_version>", "packageA =
<new_version>" hides it.
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups