Mailinglist Archive: opensuse-buildservice (175 mails)

< Previous Next >
Re: [opensuse-buildservice] Installing on Mandriva via OBS repo
  • From: alexander barakin <alex.barakin@xxxxxxxxx>
  • Date: Tue, 18 Oct 2011 23:07:16 +0400
  • Message-id: <CAFYkRnQOMz=3r9E04A-eo2np09NMZRP9o4Xu4+M0unKg9ik-ew@mail.gmail.com>
On Mon, Oct 17, 2011 at 15:55, Adrian Schröter <adrian@xxxxxxx> wrote:
Am Montag, 17. Oktober 2011, 13:48:18 schrieb Adrian Schröter:
Alex,

atm I get this error on SLE 11 SP 1. I suppose that the original rpm
package
is too old, but I do not want to replace such a core package with an
unmaintained one. Do you have a solution for this ?

Happens also on current openSUSE Factory

i fix it in factory: add pkg-config to buildreqs·

but this does not work for sle11·
i see in log:
Package rpm was not found in the pkg-config search path.
Perhaps you should add the directory containing `rpm.pc'
to the PKG_CONFIG_PATH environment variable
No package 'rpm' found

i understand that rpm-devel package from sle11 does not contain
/usr/lib/pkgconfig/rpm.pc and therefore command "pkg-config --libs
rpm" failes·
in what package can be this file?
or how else can i get LDFLAGS for rpm in sle11?

jfyi: in opensuse.11.4 and opensuse.factory command "pkg-config --libs
rpm" returns "-lrpm -lrpmio"

--
wbr, alexander barakin aka sash-kan. http://gnu.linuxcenter.ru
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-buildservice+owner@xxxxxxxxxxxx

< Previous Next >