Mailinglist Archive: opensuse-buildservice (225 mails)

< Previous Next >
Re: [opensuse-buildservice] Failed to setup an OBS private instance from 2.2.90 Appliance
  • From: "Dominig ar Foll (Intel OTC)" <dominig.arfoll@xxxxxxxxx>
  • Date: Wed, 28 Sep 2011 14:47:38 +0200
  • Message-id: <4E83176A.20403@fridu.net>
Xavier,

we are just finishing one new drop from the Obs Light project which is an OBS appilance ready to run preconfigured for MeeGo remote use.

You will find it here :
http://susegallery.com/a/e0uuBG/meego-obs

We as soon that we find where to host the 30GB tar of the MeeGo 1.2 boot strap, we will publish it as well.

We have fixed many issue related to the configuration of IP addresses changes during OBS appliance installation which shoudl help you.

Feed back is welcomed.

-- Dominig

Dominig ar Foll
Architect MeeGo IVI and TV.
Intel Open Technology Centre





Le 28/09/2011 11:18, JAFFREZIC Xavier a écrit :
Hi everybody

I've tried to start from scratch an OBS Private instance from the 2.2.90
appliance (64 bits) .
Preparing the Raid1 Disk Array and Writing the Appliance to a dedicated Disk
were fine.
The Appliance boot successfully and recognize my Raid Array a LVM .

Then I have updated the 2 following files
- /etc/sysconfig/proxy
- /usr/lib/obs/server/BSConfig.pm

In order to match my firewall settings
Then I reboot the appliance and everything were still fine

So I tried to my OBS instance to be Remotely linked to another using the WebUI
Whatever the target (opensuse or Meego) this failed . An I get :

OBS Web Interface Error:
Error Details:
Errorcode: unknown
Message: xpath for delete did not give exactly one node!"

Because, I have setup a Private instance with the 2.2.84 (32bits), I have a
copy of a working configuration file for this. So, I decided to create manually
the raw config File (using my backup):
<project name="Linked_Build">
<title>Remote access to OBS MeeGo Server</title>
<description></description>
<remoteurl>https://api.meego.com/public</remoteurl>
<person userid="Admin" role="maintainer"/>
<person userid="Admin" role="bugowner"/>
</project>

This config was accepted by the WebUI.

Then I have created another project which id pointing to this one.
<project name="Applications">
<title>User applications with HMI</title>
<description></description>
<person userid="Admin" role="maintainer"/>
<person userid="Admin" role="bugowner"/>
<repository name="Builds">
<path project="Linked_Build:MeeGo:1.2:oss" repository="standard"/>
<arch>armv8el</arch>
<arch>i586</arch>
</repository>
</project>

This was well accepted from the UI.

Then I upload a package in this project . This Package was successfully
building on my previous instance .
After uploading , nothing occurs (No Start building.)

then I walk in the UI and in the repository page, I found the "trigger rebuild"
button . When cliking the UI says :
remote error: access denied

To check my OBS connectivity, I've used osc from another computer with the
following .oscrc
[general]
apiurl = https://10.220.95.219:444
su-wrapper = sudo
no_verify = 1

[https://10.220.95.219:444]
keyring=1

Where 10.220.95.219 is the IP of my OBS server
When I'am launching the following command :

osc ls Linked_Build:MeeGo:1.2:oss

I can see the full listing for the MeeGo:1.2:oss packages. So the connectivity
of my OBS looks right (Correct firewall configuration)

What I'am missing in the configuration ? Do I need to some tweaking ?
Should I switch back to 2.2.84 (oups . Is there still some image online ?)

-- Disclaimer ------------------------------------
Ce message ainsi que les eventuelles pieces jointes constituent une
correspondance privee et confidentielle a l'attention exclusive du destinataire
designe ci-dessus. Si vous n'etes pas le destinataire du present message ou une
personne susceptible de pouvoir le lui delivrer, il vous est signifie que toute
divulgation, distribution ou copie de cette transmission est strictement
interdite. Si vous avez recu ce message par erreur, nous vous remercions d'en
informer l'expediteur par telephone ou de lui retourner le present message,
puis d'effacer immediatement ce message de votre systeme.

*** This e-mail and any attachments is a confidential correspondence intended
only for use of the individual or entity named above. If you are not the
intended recipient or the agent responsible for delivering the message to the
intended recipient, you are hereby notified that any disclosure, distribution
or copying of this communication is strictly prohibited. If you have received
this communication in error, please notify the sender by phone or by replying
this message, and then delete this message from your system.


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
References