Mailinglist Archive: opensuse-buildservice (225 mails)

< Previous Next >
Re: [opensuse-buildservice] compiler flags issue on openSUSE 11.2 (gcc4.4.1) and factory
Hi,

do you have a pointer to the code?

You can check config.log what is breaking here.

Ciao, Marcus

On Sat, Sep 17, 2011 at 04:52:27PM -0700, Di Pe wrote:
Hi, last year you helped me fixing this error in package msktutil, now
the issue is back, but only in factory, export SUSE_ASNEEDED=0 is set
but it does not seem to work any more.


checking for sasl/sasl.h... yes
checking for krb5_init_context in -lkrb5... yes
checking for ldap_initialize in -lldap... yes
checking whether com_err.h needs extern "C"... configure: error:
Couldn't get error_message to work.
error: Bad exit status from /var/tmp/rpm-tmp.08dleq (%build)


On Sat, Apr 17, 2010 at 12:54 AM, Marcus Meissner <meissner@xxxxxxx> wrote:
On Fri, Apr 16, 2010 at 08:10:23PM -0700, Di Pe wrote:
OK, did that but halts before it can finish the configure. Is there
another way to access the logs?

an alternative solution would be:

ln -s /usr/include/et/com_err.h /usr/include/com_err.h

that's how I got it to work on my own box. But I could not do that in
the build service because I was getting permission denied errors.

No, the issue is different...

To fix it, add right after the line
%build

the line
export SUSE_ASNEEDED=0

Ciao, Marcus



--
Working, but not speaking, for the following german company:
SUSE LINUX Products GmbH, HRB 16746 (AG Nuernberg)
Geschaeftsfuehrer: Jeff Hawn, Jennifer Guild, Felix Imendoerffer
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
This Thread
References