Mailinglist Archive: opensuse-buildservice (272 mails)

< Previous Next >
Re: [opensuse-buildservice] nothing provides ciutils (was Unresolvable: nothing provides: kiwi-filesystem:ext4)
  • From: Javier Llorente <javier@xxxxxxxxxxxx>
  • Date: Thu, 18 Nov 2010 12:50:35 +0100
  • Message-id: <201011181250.39333.javier@xxxxxxxxxxxx>
El Lunes, 8 de Noviembre de 2010 11:35:36 Michael Schroeder escribió:
On Sat, Nov 06, 2010 at 12:04:47AM +0100, Javier Llorente wrote:
El Viernes, 5 de Noviembre de 2010 18:28:33 usted escribió:
On Fri, Nov 05, 2010 at 06:11:23PM +0100, Javier Llorente wrote:
I am trying to build an OEM image using the Build Service/KIWI and
I'm getting the following error:

"Unresolvable: nothing provides: kiwi-filesystem:ext4"

I have the following line in my projectconfig:
Substitute: kiwi-filesystem:ext4 e2fsprogs procps psmisc

https://build.opensuse.org/project/prjconf?project=spins%3Aopen-pc%3A
imag es

open-pc-release builds if I change the filesystem to ext3 in my kiwi
config file but I would like to use ext4.

So, what am I doing wrong?

I think it's because the repositories specified in the kiwi file do not
include the "spins:open-pc:images" project.

(If no path is specified in the "images" repository, the packages used
to set up the kiwi build environment are taken from the repositories
specified in the kiwi file. The build configuration is also derived
from that repository list.)

So either add "spins:open-pc:images" to the repository list or move the
Substitute into the spins:open-pc:11.3 project config.

I don't understand. There are no rpm packages in spins:open-pc:images, so
why would it be needed?

So that the project config is used. The build config is generated
by concatenating all the project configs from the repositories
used to set up the build.

Cheers,
Michael.

Thanks for your response.

I did what you said and now the "Unresolvable: nothing provides: kiwi-
filesystem:ext4" is fixed, nevertheless I'm getting "nothing provides
ciutils." This package is part of the "Substitute: kiwi-boot:oemboot ..."
Any hints?

Greetings,
--
Javier Llorente
< Previous Next >