Mailinglist Archive: opensuse-buildservice (272 mails)

< Previous Next >
[opensuse-buildservice] osc co doesn't work while using cntlm proxy
  • From: <Praveen_Paladugu@xxxxxxxx>
  • Date: Tue, 9 Nov 2010 14:00:59 -0600
  • Message-id: <0F7A61B0A6ABAD4A82DDEF8CCA0ADA2B4DAF91D215@xxxxxxxxxxxxxxxxxxxxxxxxxx>
Hi All,

I am using cntlm (version 0.35.1-1) proxy to talk to outside network. With the
proxy configured properly, I am able to run:

" osc log prjname/pkgname" command and get the expected output.

But, when I run

"osc co prjname/pkgname" command, I get

Server returned an error: HTTP Error 502: Proxy Error ( The HTTP message
includes an unsupported header or an unsupported combination of headers. )

I tried the above osc command with "-H" flag to check the HTTP headers. The
failure occurs the first time, osc tries to download a file. From what I
noticed, the header the proxy server is having a problem with is:

Content-Disposition: attachment; filename = "kiwi.spec"

Has anybody seen this problem? Is there a known workaround?

Is there a different proxy server package (in place of cntlm) I can try, which
works with osc?

Thank you

< Previous Next >