Mailinglist Archive: opensuse-buildservice (245 mails)

< Previous Next >
Re: [opensuse-buildservice] How to delete old binaries from packages that don't exists anymore?
  • From: Cristian Morales Vega <cmorve69@xxxxxxxx>
  • Date: Thu, 7 Oct 2010 22:29:26 +0200
  • Message-id: <AANLkTimZB0y6T9EzjkT2fx26OuZpsOhAqNyvrh69YjvZ@xxxxxxxxxxxxxx>
2010/10/7 Tejas Guruswamy <masterpatricko@xxxxxxxxx>:
On 07/10/10 17:53, Cristian Morales Vega wrote:
2010/10/7 Cristian Morales Vega <cmorve69@xxxxxxxx>:

2010/10/7 Dirk Müller <dmueller@xxxxxxx>:

On Thursday 07 October 2010, Cristian Morales Vega wrote:

An "osc ls -b home:RedDwarf -r openSUSE_11.3 -a x86_64" returns things


But I deleted the "opensc" package in my home repo long ago. Since it
doesn't exists anymore I can't use osc wipebinaries. What can I do?

run wipebinaries on the project - that should clean it up.

I tried with every option but --all and didn't work. If nobody needs
the current status to make some forensics I will use --all this
afternoon even if that will mean a rebuild of every package.

Not even an "osc wipebinaries --all home:RedDwarf" worked!

I discovered you need to have publishing enabled for wipebinaries to
make the binaries to disappear from download.o.o.
Or are the binaries not disappearing even on build.o.o?

They disappear from download.o.o. It's just that they are kept
available for other packages to build against them in build.o.o. Some
are deleted, but other aren't... specially (only?) the RPMs from
packages that don't exist anymore.
I would expect to be able to do "osc api -X DELETE <something>"... but
no idea about the <something> part.
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >