Mailinglist Archive: opensuse-buildservice (332 mails)

< Previous Next >
Re: [opensuse-buildservice] "osc build --prefer-pkgs=dir" stopped working
  • From: Petr Mladek <pmladek@xxxxxxx>
  • Date: Mon, 26 Jul 2010 10:25:17 +0200
  • Message-id: <1280132717.7367.7.camel@xxxxxxxxxxxx>
Adrian Schröter píše v So 24. 07. 2010 v 09:39 +0200:
On Friday 23 July 2010 21:12:27 Petr Mladek wrote:
Adrian Schröter píše v Pá 23. 07. 2010 v 18:38 +0200:
On Friday 23 July 2010 17:58:29 Petr Mladek wrote:

I get the following error:

--- cut ---
$> osc build
SLE_11_SP1 x86_64 OpenOffice_org-bootstrap.spec
Building OpenOffice_org-bootstrap.spec for SLE_11_SP1/x86_64
Scanning the following dirs for local
packages: /prace/RPMS/ooo-
Getting buildinfo from server and store
Server returned an error: HTTP Error 400: Bad Request
remote error: Can't use an undefined value as a HASH reference at
build/ line 392.
--- cut ---

I have tried to update to the latest osc-0.128-2.1.x86_64.rpm but it did
not help.

It worked yesterday.

Can you try the build.rpm from openSUSE:Tools:Unstable project ?

I installed osc-0.128-121.1 from the
and it did not help.

Please update build package also and try again.

I tried
and it still gives the same error.

My colleague see it as well. It seems to be reproducible with any user,
any package, bs, ibs, ...

Otherwise send me the


The file is empty. I think that it is related to the "HTTP Error 400:
Bad Request".

Best Regards,

Petr Mladek
software developer
SUSE LINUX, s. r. o. e-mail: pmladek@xxxxxxx
Lihovarská 1060/12 tel: +420 284 028 952
190 00 Prague 9 fax: +420 284 028 951
Czech Republic

To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >