Mailinglist Archive: opensuse-buildservice (306 mails)

< Previous Next >
[opensuse-buildservice] multiple repositories per project not working for openSUSE:Tools (libassuan-devel-2.0.0)
  • From: Sven Uebelacker <sven@xxxxxxxxxxxxxx>
  • Date: Tue, 29 Jun 2010 17:14:24 +0200
  • Message-id: <20100629151424.GG16942@xxxxxxxxxxxxxxxxxxxxxxxxxx>
Hi,

I'm trying to build gnupg-pkcs11-scd[1] but I'm stuck adding a second repo to
the project. My raw project config includes it already like it's documented[2]:

# <repository name="openSUSE_11.2">
# <path project="openSUSE:11.2" repository="standard"/>
# <path project="openSUSE:Tools" repository="openSUSE_11.2"/>
# <arch>i586</arch>
# <arch>x86_64</arch>
# </repository>

I need libassuan-devel >= 2.0.0 to build it. Without the version strings it
breaks because it needs libassuan-devel in version 2. This package is located
in the openSUSE:Tools repo [3], I inserted it to the project config, but it
seems it isn't using it.

Do I have to specify the second repo additionally in the spec file? The
documentation [2] is very short though.

Maybe "libassuan-devel >= 2.0.0" as a BuildRequires in my specfile is wrong? I
tried many variations...

# rpm -qp --provides libassuan-devel-2.0.0-4.1.x86_64.rpm
libassuan-devel = 2.0.0-4.1
libassuan-devel(x86-64) = 2.0.0-4.1


Any ideas?
Thanks,
Sven.


[1]
https://build.opensuse.org/package/show?package=gnupg-pkcs11-scd&project=home%3Auebelhacker
[2]
http://en.opensuse.org/Build_Service/Tips_and_Tricks#Adding_multiple_repositories_to_a_project
[3]
http://ftp.halifax.rwth-aachen.de/opensuse/repositories/openSUSE:/Tools/openSUSE_11.2/x86_64/libassuan-devel-2.0.0-4.1.x86_64.rpm

--
Facebook's Eroding Privacy Policy: A Timeline
http://www.eff.org/deeplinks/2010/04/facebook-timeline/
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups