Mailinglist Archive: opensuse-buildservice (348 mails)

< Previous Next >
Re: [opensuse-buildservice] osc co/up hangs and eventually corrupts working copy
On 2010-04-27 18:53:07 +0200, Olaf Hering wrote:
On Tue, Apr 27, Adrian Schröter wrote:

Once I ran the same osc command for my project, I experienced the same
hangs. Most of the time 2MB of a file were downloaded, then osc hung.
If interrupted with ctrl c, osc may eventually be able to continue with
'osc up'. I tried it many times. osc downloads a block of 1048576 or
2097152 bytes, then it stops.
This morning I was finally able to finish a fresh checkout after a few

Can you please retry with "osc -d ..." and look from where these packages
are comming ?

-d shows all files coming from

That's correct.

It might be an api problem or a mirror problem, because osc tries first
to use redirector. is not listed in the local named log, only is.

That's correct, too.

But the thing is: once more packages get added via the webinterface an
'osc up' inside the local working copy will hang as well. If interrupted
it will corrupt the working copy by adding a new incomplete directory.
Several 'osc up' runs will stop with 'directory XY does already exist'.
Removing that XY directory does seldom help.

Hm, do you use some proxy or anything else what makes your setup special ?
I am not aware that anyone else has such problems atm.

right, local corruption should not happen in any case.

Its the way files and metadata are downloaded.
If they are downloaded and stored in the correct order, osc can be more
robust and handle such situations.

Yes osc should handle this more gracefully. I'm currently working on a
small working copy restructuring which will make the whole update easier
and more robust. At the moment I'm a bit busy but it's WIP.. :)

So, this can not be a load problem IMHO, but maybe we have a bug somewhere.
I just wonder what is triggering this and how we can reproduce it.

I can trigger it most of the time.
According to the 'time osc -v -v -d -H up --unexpand-link' output, it
can hang in any of the GET requests:


Unfortunately I can't reproduce it locally:/

To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >