Mailinglist Archive: opensuse-buildservice (348 mails)

< Previous Next >
Re: [opensuse-buildservice] osc co/up hangs and eventually corrupts working copy
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Tue, 27 Apr 2010 09:44:37 +0200
  • Message-id: <201004270944.37621.adrian@xxxxxxx>

Moin Olaf!

Am Montag, 26. April 2010 17:16:11 schrieb Olaf Hering:

This weekend I tried to run the following command several times:

osc co --unexpand-link home:duwe:crosstools

The cross-* packages which are linked were downloaded without issues,
but as soon as the master-binutils package is supposed to be downloaded,
osc hangs.
lsof shows that 2MB of binutils-tar.bz2 are downloaded, quickly, but
then osc hangs for many hours (or even days, I havent tried) without
progress nor error messages.

In parallel, I rolled my own via the web interface, which works really
nice. Retreiving packages from remote safes me the slow upload from my

Once I ran the same osc command for my project, I experienced the same
hangs. Most of the time 2MB of a file were downloaded, then osc hung.
If interrupted with ctrl c, osc may eventually be able to continue with
'osc up'. I tried it many times. osc downloads a block of 1048576 or
2097152 bytes, then it stops.
This morning I was finally able to finish a fresh checkout after a few

Can you please retry with "osc -d ..." and look from where these packages
are comming ?

It might be an api problem or a mirror problem, because osc tries first
to use redirector.

But the thing is: once more packages get added via the webinterface an
'osc up' inside the local working copy will hang as well. If interrupted
it will corrupt the working copy by adding a new incomplete directory.
Several 'osc up' runs will stop with 'directory XY does already exist'.
Removing that XY directory does seldom help.

Hm, do you use some proxy or anything else what makes your setup special ?
I am not aware that anyone else has such problems atm.

Is there a way to fix the local working copy from such breakage?
Doing a fresh checkout is appearently no option, as it starts to hang

Perhaps the servers should return some sort of EBUSY right away when
they cant service the 'checkout/update' request. This would prevent the
local corruption and it probably reduces the load on the servers,
because repeated checkout attempts may put even more pressure on them.

right, local corruption should not happen in any case.
But the api and source server have usually a relative low load. We have splitted
them away from the loaded binary/scheduling server to guarantee short answer

So, this can not be a load problem IMHO, but maybe we have a bug somewhere.
I just wonder what is triggering this and how we can reproduce it.

But it can be of course also just a broken router on your side ...

I'm using osc 0.125.5 on openSuSE 11.2-x86_64.

Should be fine



Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx

To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups