Mailinglist Archive: opensuse-buildservice (216 mails)

< Previous Next >
Re: [opensuse-buildservice] "BuildRequires: ant" causes "have choice for java-devel"
  • From: "Dominique Leuenberger" <Dominique.Leuenberger@xxxxxxxxxxxxx>
  • Date: Wed, 17 Mar 2010 09:38:20 +0100
  • Message-id: <4BA0A30C0200002900095CE6@xxxxxxxxxxxxxxxxxxx>
On 3/17/2010 at 4:58, Douglas Hubler <douglas@xxxxxxxxx> wrote:
When i include ant, i get build error
have choice for java-devel needed by ant: java-1.6.0-sun-devel
java-1.4.2-gcj-compat-devel java-1.6.0-openjdk-devel

I've tried specifying a specific java in *my* spec file
BuildRequires:

and listing it *before* the "BuildRequires: ant" but it still leads to
the same error because it's ant that is complaining. Is there anyway
to force a particular java globally? or restrict other packages from
being an option?

You will have to specify one of the offered choices, which are:
java-1.6.0-sun-devel
java-1.4.2-gcj-compat-devel
java-1.6.0-openjdk-devel

As you can see, they all end in -devel. What you specified (java-1.6.0-sun)
does not answer the question the build system would run into.

Dominique
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
References