Mailinglist Archive: opensuse-buildservice (182 mails)

< Previous Next >
Re: [opensuse-buildservice] after latest update (1.6.99-114.1) load is very high
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Thu, 11 Feb 2010 14:20:09 +0100
  • Message-id: <201002111420.09615.adrian@xxxxxxx>
Am Donnerstag, 11. Februar 2010 14:12:48 schrieb Jon Nelson:
On Mon, Feb 8, 2010 at 3:01 AM, Stephan Kulow <coolo@xxxxxxx> wrote:
Am Freitag 05 Februar 2010 schrieb Jon Nelson:
After updating to the latest obs* packages (1.6.99-114.1) load is very
high.

I see a load of between 8 and 10. Since I have two workers going, I'd
expect to see a load of more like 2 or occasionally 3.

The logs show *lots* "GET /workerstatus?" to the rep_server, and "GET
/build/_workerstatus" to the src_server, and the delayed_job log is
constantly noisy.

Upgraded to 1.7.0

It turns out to be the delayed job code.
Every second (as in 60 times a minute) it is requesting _workerstatus
and inserting 5 rows into status_histories and DELETING rows from
delayed_jobs. Also an UPDATE in there, too. Is there anything that
will prune those tables? Is it really necessary to run once every
second?

it doesn't usually. But you had most likely a backlog which it had to process.

Load does return to normal-ish after a while, 0.1 instead of 0.0.
I'll see if it comes back.




--

Adrian Schroeter
SUSE Linux Products GmbH
email: adrian@xxxxxxx

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups