Mailinglist Archive: opensuse-buildservice (260 mails)

< Previous Next >
Re: [opensuse-buildservice] .deb build help -- "can not parse package name from spec file"
If I had to take a guess, I would just say your .dsc is over specifying
the version. Here's the .dsc I made for python-keyring (so you have a
spec to which to compare):

Format: 1.0
Source: python-keyring
Version: 0.2.1-1
Binary: python-keyring
Maintainer: Luke Imhoff <luke@xxxxxxxx>
Architecture: all
Standards-Version: 3.7.1
Build-Depends: debhelper (>= 4.0.0), kdelibs4-dev, libgnome-keyring-dev,
libqt3-headers, python-all-dev, python-support

The version is only on the Version line, the Source and Binary don't
contain it. Also, the debian build tools will just assume the source
tarball name, I don't think it's strictly necessary to have a Files
section.

Then the debian/control file is

Source: python-keyring
Section: devel
Priority: extra
Maintainer: Luke Imhoff <luke@xxxxxxxx>
Build-Depends: debhelper (>= 4.0.0), kdelibs4-dev, libgnome-keyring-dev,
libqt3-headers, python-all-dev, python-support
XS-Python-Version: >= 2.3
Standards-Version: 3.7.1

Package: python-keyring
Architecture: all
XB-Python-Version: ${python:Versions}
Depends: ${misc:Depends}, ${python:Depends}
Provides: ${python:Provides}
Description: Generic keyring library for python applications. It can be
usedstand
alone or with wrapper plugins for KDE or Gnome.

So, the Source name in the .dsc needs to match the Source name in
debian/control (or debian.control). Finally, the actual binary version
for debs is generated from the changelog, so the last entry in
debian/changelog has to match the Version in the .dsc

python-keyring (0.2.1-1) unstable; urgency=high

- Build for Ubuntu 9.1

-- Luke Imhoff <luke@xxxxxxxx> Thu, 03 Dec 2009 14:17:32 -0600

It actually turns out the Version in the .dsc can be wrong, and it just
matters that the version in the changelog matches the tarball version
for the build to work, but you do need the Version line in the .dsc or
the build will not work.

On Thu, 2009-12-10 at 01:22 -0600, Nicholas Tung wrote:
On Wed, Dec 9, 2009 at 1:31 AM, Michael Schroeder <mls@xxxxxxx> wrote:
On Tue, Dec 08, 2009 at 02:56:19PM -0800, Nicholas Tung wrote:
I'm following the documentation at
http://en.opensuse.org/Build_Service/Deb_builds

for building a .deb file. However, I keep seeing the error, "can
not parse package name from spec file". My project is here,
https://build.opensuse.org/package/show?package=sketch-cegis&project=home:gatoatigrado1

This may be a bug in the dsc file parser, you currently must not
have empty lines in the dsc file.
I'll check the specification.

(I already fixed the error message, this is not about a "spec file".)

Cheers,
Michael.

Thanks very much, that fixed that error. Unfortunately, I'm getting another,

dpkg-buildpackage: error: unable to determine source changed by
dpkg-buildpackage: source package sketch-backend
dpkg-buildpackage: source version 1.4.0

It would be super-awesome if obs could generate debian packaging info,
or maybe use existing tools (maybe alien).

thanks much,
Nicholas


--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >