Mailinglist Archive: opensuse-buildservice (311 mails)

< Previous Next >
RE: [opensuse-buildservice] Restricting a build to certain workers
  • From: <Michael_E_Brown@xxxxxxxx>
  • Date: Wed, 11 Nov 2009 15:42:19 -0600
  • Message-id: <23FB5629F59DB0438C772CCC7352E5B9B7363B@xxxxxxxxxxxxxxxxxxxxxxxxxxxxx>
-----Original Message-----
From: Adrian Schröter [mailto:adrian@xxxxxxx]

Am Mittwoch, 11. November 2009 22:09:30 schrieb Luke Imhoff:
The official OBS doesn't even support SLES 9 because it can't run Xen,
but it worked fine to build SLES 9, 10, and 11 in a chroot, which is
what we needed up until this point.

You should be also fine with using eg using the SLES 11 xen and run SLES 9
builds inside. package building may brake on too old kernels, but it should
(famous last words) never do on too new.

Problems:
-- it takes time and downtime to get things upgraded
-- If you are using scavenged infrastructure, you may not be able to upgrade
(ie. running workers on machines purposed for other things to soak up unused
cycles.)

--
Michael
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups