Mailinglist Archive: opensuse-buildservice (311 mails)

< Previous Next >
Re: [opensuse-buildservice] local obs server setup problems
  • From: Doug Reiland <dreiland@xxxxxxxxx>
  • Date: Thu, 5 Nov 2009 19:22:48 -0500
  • Message-id: <6844644e0911051622s5180e6aaw7f5864bb2cd7bec8@xxxxxxxxxxxxxx>
There was a log file that was root.root, but I changed it and made the
log directories g+s, but it didn't change anything.

Also, I ran:
su - lighttpd -c /srv/www/obs/frontend/public/dispatch.fcgi

but it came right back to the shell prompt. Would you expect to see
output or errors?

Thanks again,
Doug


On Thu, Nov 5, 2009 at 10:30 AM, Michael E Brown
<Michael_E_Brown@xxxxxxxx> wrote:
On Thu, Nov 05, 2009 at 06:55:56AM -0500, Doug Reiland wrote:
I think I so your old problem, and checked/changed the permissions
before I posted here.
My log directories are:

ls -sld /srv/www/obs/*/log
4 drwxr-xr-x 2 lighttpd lighttpd 4096 2009-04-08 16:05 common/log
4 drwxr-xr-x 2 lighttpd lighttpd 4096 2009-11-04 05:17 frontend/log
4 drwxr-xr-x 2 lighttpd lighttpd 4096 2009-11-04 05:28 webclient/log

Do these match yours? Are there other files?

Yes, those match mine. If you had to change them, then adrians needs to know
so he can fix the packaging.

You also need to check the actual log files themselves. Mine were owned by
root (broken) until I chown-ed them to lighttpd (correct):

ls -la /srv/www/obs/*/log/*
-rw-r--r-- 1 lighttpd lighttpd   70714506 2009-11-05 09:28
/srv/www/obs/frontend/log/backend_access.log
-rw-r--r-- 1 lighttpd lighttpd          0 2009-05-21 19:21
/srv/www/obs/frontend/log/development.log
-rw------- 1 lighttpd lighttpd      24082 2009-11-03 18:01
/srv/www/obs/frontend/log/fastcgi.crash.log
-rw------- 1 lighttpd lighttpd  308241393 2009-11-05 09:28
/srv/www/obs/frontend/log/obs-frontend-access.log
-rw------- 1 lighttpd lighttpd 1118977319 2009-11-05 09:28
/srv/www/obs/frontend/log/production_slave.log
-rw-r--r-- 1 lighttpd lighttpd       1657 2009-05-21 18:28
/srv/www/obs/webclient/log/development.log
-rw------- 1 lighttpd lighttpd      28671 2009-11-03 18:01
/srv/www/obs/webclient/log/fastcgi.crash.log
-rw------- 1 lighttpd lighttpd   96817552 2009-11-04 16:15
/srv/www/obs/webclient/log/obs-webclient-access.log
-rw------- 1 lighttpd lighttpd   96644401 2009-11-04 16:15
/srv/www/obs/webclient/log/production_slave.log


The next thing you can do, and forgive me because I'm no expert on this and
am doing this from memory, you should run the
'/srv/www/obs/frontend/public/dispatch.fcgi' by hand (su - lighttpd -c
/srv/www/obs/frontend/public/dispatch.fcgi) to see what the error message it
gives you is.

--
Michael

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >