Mailinglist Archive: opensuse-buildservice (171 mails)

< Previous Next >
[opensuse-buildservice] Re: Setup obs on localhost -- About api interface error "
  • From: 李建 <lijian.gnu@xxxxxxxxx>
  • Date: Thu, 3 Sep 2009 19:43:51 +0800
  • Message-id: <426c385a0909030443i1a1670cdse2c2d3aa9e7a2c8@xxxxxxxxxxxxxx>
Sorry, but maybe I'm found the "localhost" defined in
/srv/www/obs/frontend/config/environments/production_slave.rb

---------------------------------
25 SOURCE_HOST = "localhost"
26 SOURCE_PORT = 6362
=======================

because, I modified it as following just now:
--------------------------------------------
25 #SOURCE_HOST = "localhost"
26 SOURCE_HOST = "172.16.70.28"
27 #SOURCE_PORT = 6362
28 SOURCE_PORT = 81
=======================

restart all service ,then run command:
---------------------------------------------
# osc build standard i586 lighttpd.spec
Building lighttpd.spec for standard/i586
Getting buildinfo from server
jianlee: apiurl=http://172.16.70.28:81/, prj=home:jianlee,
package=lighttpd, platform=standard, arch=i586, addlist=['vim', 'gdb',
'strace']
jianlee: query = ['add=vim', 'add=gdb', 'add=strace']
jianlee:
u=http://172.16.70.28:81/build/home:jianlee/standard/i586/lighttpd/_buildinfo?add=vim&add=gdb&add=strace
'NoneType' object has no attribute 'text'
===========================

different errors,

But, I'm puzzled what's the service about here??


Thanks !

2009/9/3 李建 <lijian.gnu@xxxxxxxxx>:
Hi, guys

I'm following osc to
"http://172.16.70.28:81/build/home:jianlee/standard/i586/lighttpd/";
when exec command "osc build standard i586 lighttpd.spec"

-----------------------------------------------
# osc build standard i586 lighttpd.spec
Building lighttpd.spec for standard/i586
Getting buildinfo from server
jianlee: apiurl=http://172.16.70.28:81/, prj=home:jianlee,
package=lighttpd, platform=standard, arch=i586, addlist=['vim', 'gdb',
'strace']
jianlee: query = ['add=vim', 'add=gdb', 'add=strace']
jianlee:
u=http://172.16.70.28:81/build/home:jianlee/standard/i586/lighttpd/_buildinfo?add=vim&add=gdb&add=strace
wrong repo/arch?
===========================

the string begined by "jianlee:" in above text is my debug print.

I found the error occured at request
"http://172.16.70.28:81/build/home:jianlee/standard/i586/lighttpd/";
when use firefox to request this url, I've get "unknown host
'localhost.dev.cn.tlan'"

the ".dev.cn.tlan" is my domainname in local network. the "localhost"
is my hostname.
I'm puzzled, where to modified the "localhost" conect for obs ?

my /etc/lighttpd/vhosts.d/obs.conf is :

--------------------------------------------
# cat /etc/lighttpd/vhosts.d/obs.conf
$HTTP["host"] =~ "172.16.70.28\.?" {
rails_app = "webclient"
rails_root = "/srv/www/obs/webclient"
rails_procs = 5
# production/development are typical values here
rails_mode = "production_slave"

log_root = "/srv/www/obs/webclient/log"

include "vhosts.d/rails.inc"
}
$SERVER["socket"] == "172.16.70.28:81\.?" {
rails_app = "frontend"
rails_root = "/srv/www/obs/frontend"
rails_procs = 5
# production/development are typical values here
rails_mode = "production_slave"

log_root = "/srv/www/obs/frontend/log"

include "vhosts.d/rails.inc"
}
$SERVER["socket"] == "172.16.70.28:82\.?" {
server.name = "download.turbo"

server.document-root = "/srv/obs/repos/"
# server.document-root = "/srv/obs/build/"
}
==============================


Thanks,



--
Jian Lee [ http://jianlee.ylinux.org ]




--
Jian Lee [ http://jianlee.ylinux.org ]
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
This Thread
References