Mailinglist Archive: opensuse-buildservice (262 mails)

< Previous Next >
[opensuse-buildservice] py_requires RPM macro doesn't seem to expand
  • From: Vincent Petry <PVince81@xxxxxxxx>
  • Date: Sun, 02 Aug 2009 12:35:05 +0800
  • Message-id: <4A751779.3010805@xxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

I am trying to compile a python module by following this
documentation: http://en.opensuse.org/Packaging/Python

The problem I meet with my local OBS build is that it says "Failed
build dependencies, can't find python". It looks like the
%{py_requires} macro is not expanded at all.

I tried another way by adding "BuildRequires: python =
%{py_ver}.%{py_ver}", but it seems that the %{py_ver} macro also
doesn't expand at all.

The only way that works is adding python manually but without the
version informatin. But then I get this rpmlint warning:
python-rabbyt.i586: W: no-dependency-on python 2.6

Can you help me to clear out this issue ?

Thanks,

Vincent Petry
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org

iEYEARECAAYFAkp1F3kACgkQSSdxpfEEQEyZ7ACfd+Htfi3wgOl57mst2T1SjbOa
HfQAnA250p+4cSHAdaOsHA1nC4Z4lrls
=lufj
-----END PGP SIGNATURE-----

--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups