Mailinglist Archive: opensuse-buildservice (206 mails)

< Previous Next >
Re: [opensuse-buildservice] Adding autoconf213 to the standard repository
  • From: Anshul Jain <anshulajain@xxxxxxxxx>
  • Date: Thu, 26 Mar 2009 12:18:48 +0530
  • Message-id: <606f7fb50903252348o44703fe6y556b5a85e395c244@xxxxxxxxxxxxxx>
On Thu, Mar 26, 2009 at 11:23 AM, Stephen Shaw <sshaw@xxxxxxxxxxxxx> wrote:
I'm trying to build FF3.1 beta w/ subpixel hinting through the BS.
I've modified the spec file and added all the source files into the
repository. However, I'm missing autoconf213 in the Opensuse 11.0 and
11.1 repositories. Sure enough though, its provided by the mozilla
repo and not the official repository. So how can I link this
particular RPM to my build environment? Is there a way to install
this? Would appreciate some help! :)


There is a link that says something about linking to another project.
More importantly, you might not be allowed to build it with subpixel
hinting in obs as it violates patents.  Or at the very least have
potential legal problems.  I'm sure there are others that can comment
on the list.


Thanks for the prompt reply, can you direct me to that link? As far as
subpixel hinting is concerned, if it violates patents...I'll remove


Here is a link about the subpixel hinting stuff -

As for the linking to other packages in other projects:
Under the list of your current packages in your project (about the
middle of the screen), there are 2 links.  One is to add a new
package, [Add Package], and the second is to link to another package
in another project, [Link Package from other Project].  Once you click
on it, you will see 3 boxes.  The first one is the name of the project
that you want to connect to, the second is the name of the package,
and the third I usually leave blank, but its for if you want to name
it differently in your local project.


I found the right place to link the file, however...I couldn't quite
add autoconf213 which is present in this link:-

I tried adding "mozilla" and even
into the 1st line...and in the 2nd line I added the file It still won't take..any suggestions?


What you need is the build service project name.  Its probably
something like Mozilla.


It could be "Mozilla", "mozilla" or "mozilla/openSUSE_11.0"...neither
of them works..


the project name is (first box):

the package is(second box):

That worked for my project.


Thanks...that worked :) Now to check if the system-cairo enabled
xulrunner for mozilla will build against the autconf213 rpm.

To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >