Mailinglist Archive: opensuse-buildservice (233 mails)

< Previous Next >
Re: [opensuse-buildservice] Unresolved OBS 1.0 dependencies for SLE10
  • From: Carsten Hoeger <choeger@xxxxxxxxxxxx>
  • Date: Mon, 8 Dec 2008 11:07:40 +0100
  • Message-id: <20081208100740.GB9607@xxxxxxxxxxxx>
On Wed, Dec 03, Martin Mohring wrote:

refering to

http://lists.opensuse.org/opensuse-buildservice/2008-07/msg00064.html

there are still unsatisfied deps, e.g. yum-metadata-parser is still
missing.



I tried now to install obs from

http://download.opensuse.org/repositories/openSUSE:/Tools:/Devel/SLE_10/
http://download.opensuse.org/repositories/openSUSE:/Tools:/Unstable/SLE_10/

and

http://download.opensuse.org/repositories/openSUSE:/Tools/SLE_10/

and always get the attached conflicts :-(



I am not sure what happens. Looking into the directories shows me
yum-metadata-parser is present in all 3 cases. To solve this fast,
download yum-metadata-parser and install with rpm -Uhv <filename>, if
nothing else helps, by hand.

Maybe someone has a better Idea how this can happen?


I've been told already, that repoview isn't required, so I could ignore it.
But then I found the next problem, which is, that the ruby repo is
disabled:

https://bugzilla.novell.com/show_bug.cgi?id=455933

So currently no OBS install possible... :-(


Since Susanne was a bit fast with removing ruby on rails packages, I put
a copy of the ruby stuff back into openSUSE:Tools:Unstable and
openSUSE:Tools:Devel. So feel free to grab the ruby pkgs from there.
Removing pkgs before there is a working new solution is not so good.

I have also seen there is a problem with SLE10 at the moment. The ruby
project is off (and pkgs are not exported). So at the moment SLE 10
cannot be installed. I hope there is a fast fix.


Any update on the OBS-on-SLE10 front?
I'd like to install OBS this year. ;-)

--
With best regards,

Carsten Hoeger
< Previous Next >