Mailinglist Archive: opensuse-buildservice (266 mails)

< Previous Next >
Re: [opensuse-buildservice] Re: rpmlint error /opt/.... is not allowed anymore in FHS 2.2
  • From: Susanne Oberhauser <froh@xxxxxxxxxx>
  • Date: Mon, 10 Nov 2008 11:43:29 +0100
  • Message-id: <s2iskpzdfou.fsf@xxxxxxxxxxxxx>
Adrian Schröter <adrian@xxxxxxx> writes:

It already existed.... :
https://bugzilla.novell.com/show_bug.cgi?id=436992

However, I find the priority quite low (P5). As soon as openSUSE_11.1
becomes available I can't provide the package for 11.1... Do you think
this issue can be tackled before the 11.1 release?

We may _WANT_ to keep this check when building in the distribution.

But we may want not this check when building packages for this
distro, but keep them as an add-on.

In this case we need different checks for these both usecases. This
is why I think we need a :Compat project. However, I want discuss
this first with our build people.

The :Compat project is intended to be modified after 11.1 release,
if we follow this path.

I don't fully understand yet:

The obs is meant to build for many distros.

Packages that are built for 'other distros' almost by definition are
'third party' pacakges, which by the FHS should actually all be below
/opt, shouldn't they?

So _strictly_ speaking, only Factory should force packages out of
/opt, while all other packages should actually force packages _into_
/opt ??

Hmmm... back down to earth I just think this whole /opt thing is
half-baked, as it's currently defined by the FHS.

That said, I still don't understand what you meant by the ":Comapt"
project.


S.

--
Susanne Oberhauser +49-911-74053-574 SUSE -- a Novell Business
OPS Engineering Maxfeldstraße 5
Processes and Infrastructure Nürnberg
SUSE LINUX Products GmbH, GF: Markus Rex, HRB 16746 (AG Nürnberg)
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups