Mailinglist Archive: opensuse-buildservice (184 mails)

< Previous Next >
Re: [opensuse-buildservice] Forcing an answer to a choice question durring build
  • From: Andreas Jaeger <aj@xxxxxxx>
  • Date: Sat, 25 Oct 2008 17:39:19 +0200
  • Message-id: <8763ng8z14.fsf@xxxxxxx>
"Petit Eric" <surfzoid@xxxxxxxxx> writes:

Hi
I'm very newbie in writing spec file and most often time i use the
minimal one created by the spec wizard of WebClient.

So most of my pkg build correctly except for one who say me :
expansion error have choice for mono(Mono.Data.Sqlite) = 2.0.0.0
needed by mono-web: mono-data-sqlite mojoportal

How can i prevent this "choice" problem ?

Add a BuildRequires on either of them,

Andreas
--
Andreas Jaeger, Director Platform / openSUSE, aj@xxxxxxx
SUSE LINUX Products GmbH, GF: Markus Rex, HRB 16746 (AG Nürnberg)
Maxfeldstr. 5, 90409 Nürnberg, Germany
GPG fingerprint = 93A3 365E CE47 B889 DF7F FED1 389A 563C C272 A126
< Previous Next >
Follow Ups
References