Mailinglist Archive: opensuse-buildservice (184 mails)

< Previous Next >
Re: [opensuse-buildservice] Local build can't find previous build packages
  • From: Marcus Hüwe <suse-tux@xxxxxx>
  • Date: Tue, 21 Oct 2008 18:02:38 +0200
  • Message-id: <20081021160238.GA3133@xxxxxxxxxxxxxxxxxxx>
On 2008-10-21 09:04:35 +0200, Adrian Schröter wrote:
On Tuesday 21 October 2008 08:56:41 wrote Klaas Freitag:
Hi Davide,

dozza@barbera:~/Projects/BuildService/home:davide_dozza/OpenOffice_org-ur
e> osc build openSUSE_11.0 i586 OpenOffice_org-ure.spec
Building OpenOffice_org-ure.spec for openSUSE_11.0/i586
Getting buildinfo from server
buildinfo is broken... it says:
expansion error: nothing provides OpenOffice_org-bootstrap = 3.0.0.6

After the build the package OpenOffice_org-bootstrap is into the
directory /var/tmp/build-root/usr/src/packages/RPMS/

What I do in this case is I 'save' built packages to a directory outside
of the build root and specify that with command line switch -p to the
following calls to osc build

I am not sure if there is a better/other way.

I think this would not help here, because the server would not include local
build packages into build dependency calculation.

As long as an old version of this package is available on the server it should
work (precondition: don't use something like
"BuildRequires: foo >= <brand-new-version>", otherwise it'll lead to an
expansion error).

So I would suggest just to submit your modified OpenOffice_org-bootstrap
package, so it gets build on the server side.


Marcus
--
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >